Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

What does it say?

Be sure to have the newest version of WinRar, 123zip or whatever else you are using! It's important (and mentioned in the installation notes) because it uses a newer method that old versions cannot handle!

Thank you so much. It helped. Will there be a continuation?)