Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

UE4 games like mine require you to install Microsoft Visual c++2015 to play. Though I haven't got a clue why it's needed.