Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Thats a really good game
sadly Icant run it underlinux 64bit (Ubuntu 18.04) It says libGLU.so.1 is missing :/

Sorry about that. I  used Unity's Linux build but don't have a machine myself to test it on. Thanks for the info!

I'm on Debian so I'm a little out of my element, but I found this topic on Stack Overflow that might help.  Be sure to check the comments on the best-voted answer, too. https://stackoverflow.com/questions/22360771/missing-recommended-library-libglu-...