Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Tiled has not needed Qt5OpenGL.dll since a long time, so I think something went wrong with an upgrade. Normally you can resolve such problems by making sure all versions of Tiled are uninstalled (through Add/Remove Programs) and then to install the version of Tiled you'd like to use.