Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

hey croci.. sorry my linux build might be more hassley than it could be. still working out best practises for releasing linux stuff. i think all you need to install is SDL2. far as I can tell this should do it: 

in a terminal window, run: 

sudo apt-get install libsdl2-2.0

(or if you use a GUI package manager just search it for SDL2). pretty sure that'll be all you need but i'm on my phone rn, can't check. lemme know if it still won't work. thanks :) also good idea, i'll add a linux install note..