Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Are you using the right version of Love2D? Depending on which zip file you use, you'll need either 10.2 or 11.1.