Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
(+1)

It looks like the build still requires OS X 10.12 to run; for some reason I apparently have OS X 10.11.6 (lol), so I couldn't play it. I don't have time to upgrade right now, otherwise I would check it out--sorry! I'm guessing that a lot of people are like Max and I and haven't upgraded in forever. :/ Graphics look very nice, though!