Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
(4 edits)

I got the following ERROR when I tried to drop my boomerang:

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Draw Event
for object obj_player:

string_pos argument 2 incorrect type (undefined) expecting a String (YYGS)
############################################################################################
--------------------------------------------------------------------------------------------
called from - gml_Script_weapon_type (line 8)
called from - gml_Object_obj_player_Draw_0 (line 77)


-------------------------------

The game crashed afterwards.

Before that I successfully dropped my rifle and no error occured.

Also I crashed the game yesterday without an ERROR dialogue and I have no idea why, it might have been about the RAM allocation (I do have a lot, but I also had the game running for many hours) but that is just a guess... I can't really provide much info about that, sorry.

I'm so happy you implemented an autosave feature.


EDIT:

Oh I just posted this (not noticing a similar report has been made, sorry for the duplicate) and have already encountered another ERROR.

It happened when I tried to connect a volt meter (which was connected to a relay already) to an oil producer.

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Other Event: User Defined 0
for object obj_producer:

STRING argument is unset
############################################################################################
--------------------------------------------------------------------------------------------
called from - gml_Object_obj_producer_Other_10 (line 9)
called from - gml_Object_obj_volt_meter_Other_14 (line 6)
called from - gml_Object_obj_volt_meter_Step_0 (line 95)

-----------------------------------------------

After this ERROR I could not load the game anymore. It crashes without dialog when it reaches around 56%.

Could you advise me on how I could potentially get my save back? if it's not possible, I'll just have to deal with that, but it'd be a shame...

(+1)

There are backups created in the %localappdata% folder you can try replacing files from there (Check the dates on the files and pick a newer one).

I'll check on these errors.

(+1)

I believed I fixed both of these errors. The memory error might be a memory leak on my part (but I am pretty good at not creating those; I'll run a test, it has been awhile). Update inbound.

(+1)

Good to know and thanks for the quick response. I have just needed to replace the CAMP.ini with a backup and it worked! :)

yeah something got corrupted i guess