Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

The Ubuntu version requires the following packages to be installed:

libsdl2-2.0-0
libsdl2_mixer-2.0-0
libphysfs
libstdc++6