🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

yes

Older integrated video cards are not supported by the engine, this may be the reason. OpenGL 2.1 is required and even then some old VGA cards that do support 2.1 still crash.

Sorry, can't really do anything about it! :( Maybe try in another OS or machine if possible?

i will try it on another computer :) ps android version and ios