Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
(+1)

Doesn't run on Ubuntu 16.04 as it has a newer libXcursor, any chance of an update to work with newer versions too?