Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
(+3)

I don't know if it's me but it says it needs to be updated to be playable for my Mac. Just wanted to know if anyone else was dealing with that too?

i am also dealing with this :/

(+1)

Because your Mac OS version is higher than the game's OS version. If you really want to play this as well as other games here, you might consider buying the Crossover software that let you install and play Windows games/apps on MacOS