Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

On Debian (x64) I'm having issues with libraries, any way to fix it?

As your system is 64-bit, but the game build is 32-bit, you should install 32-bit versions of required libraries via the system's package manager.