🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

I hit the spring to go into the next biome from the forest, but apparently I somehow also fell into a hole at the same time, so once I was in the camp for the rainforest it did the whole falling animation and took away several hearts, and then I was somehow in the camp with no seed? Very strange. Hard to replicate because you need a spring to spawn very close to/inside a hole. Easiest way to fix this is probably to just make it so exit springs can't be too close to holes.

Ahhh good catch Mike. I think I saw this once before- the buffered spawning should do the trick

(Edited 1 time)

Still experiencing this issue. Note that there wasn't even a hole on the spring--no idea why I even "fell". This time I had enough hearts that I didn't die, and the vine never came back, so I just floated here soft-locked.



Weird! So let me clarify: You hit the spring, and it launched the seed up but also triggered a fall sequence? Did the screen fade and load the camp first and then you saw this? Or whats the context/leadup to this?

oooh wait I have an idea of what it could be. Did you possible have a good amount of momentum going to hit that spring from the right moving left? Technically the way we do springing you may have fallen in that hole on the left of the spring there (long story short the springing seed and the seed on the vine are separate gameobjects internally and there may be some messed up state)

Your summary is accurate, it launched me up and loaded the camp but also did the whole fall sequence. It just happened to me again, this time at the jungle->desert camp, but I don't remember about the momentum. Maybe. I'll pay better attention next time.

I think you might be right, I was just able to replicate it by hitting a spring with a lot of speed when there was a hole on the other side. The level indicator on the vine went right over the hole. Of course I forgot to capture video before I opened up the game with the intention of replicating a bug! Maybe later.

Got it on video!

Wow thanks for capturing this! This further confirms my suspicions. I'll try and tackle this one in my next round of bug squashin :]

Just pushed this fix to our repo :) whenever our next update goes live it should be gone!