Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Hi there. It's downloaded thanks, when I run the game in Spectaculator it comes up with the coding, but when I type run the game starts. This doesn't sound right. I then downloaded the Tap file which runs but the character you play flashes between letters and numbers???? 😕

(1 edit)

Hi Nigel,

Fair point about it not auto running but by not running it yourself you miss out on the nice border effect on the preparing graphics routine.  i have updated the downloads as z80 and sna snapshots whicg are default at the menu, ready to play.

I have been unable to replicate the issue about the character swapping between letters. the character itself looks like a letter i and when running could be seen as a letter k i guess but working on an 8*8 pixel boundary doesnt give you a lot of scope for detailed graphics 8) 

I have tried many flavours of spectaculator with different hardware setups but all seem normal to me.

if it is definately not graphics but letters being shown, it would be interesting to know your setup in spectaculator and a screen shot of the issue which  may help me diagnose the issue.

the main characters graphics are UDGs over the letters e through to o so it could be represented by these letters if the graphics routine has not been run through, but the snapshots have already had the graphics compiled into memory so this should not be the case.

i know emulators like retrovirtualmachine can override the model type so can run the game as a 128k model which does corrupt the game as not all UDGS are available in 128k mode but this still doesnt seem to fit what you are experiencing.

regards jason

Ok cheers. I will try a different emulator. Thanks for sorting this out.