Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Yeah, we are not working on it anymore :/ but it should be compatible with the newest version!

Afraid it's not... I get a warning message then the next screen is a crash... do you want the error message? (I'm running Linux if that's relevant).