Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

The World Begins With You

An atmospheric puzzle-platformer-adventure. · By Fabian Denter

macos The application “TheWorldBeginsWithYou_v1.0.2_MAC” can’t be opened.

A topic by frumbert created Jun 14, 2020 Views: 464 Replies: 4
Viewing posts 1 to 4

TheWorldBeginsWithYou_v1.0.2_MAC

macos 10.15.5 (19F101)

You have to go to System Preferences -> Security & Privacy and click "Open Anyway"

Unfortunately the Security & Privacy isn't listing the app at all, it isn't like it is prompting that it needs access for accessiblity/screen/disk like other apps do. Here are the relevant lines from the system console when trying to launch the game. Here is the error screen.


default 11:10:43.659831+1000 lsd Non-fatal error enumerating at <private>, continuing: Error Domain=NSCocoaErrorDomain Code=260 "The file “PlugIns” couldn’t be opened because there is no such file." UserInfo={NSURL=PlugIns/ -- file:///Applications/TheWorldBeginsWithYou_v1.0.2_MAC.app/Contents/, NSFilePath=/Applications/TheWorldBeginsWithYou_v1.0.2_MAC.app/Contents/PlugIns, NSUnderlyingError=0x7fec6311dae0 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}

default 11:10:43.659877+1000 lsd - 45683955: Checking whether application is managed at file:///Applications/TheWorldBeginsWithYou_v1.0.2_MAC.app/unity.Fabian Denter. The World Begins With You

default 11:10:43.678561+1000 Finder LAUNCHING:0x0-0x243243 TheWorldBeginsWithYou_v1.0.2_MAC foreground=1 bringForward=1 seed=545 userActivityCount=0

default 11:10:43.683779+1000 Finder spawn_via_launchd() failed, errno=111 label=[0x0-0x243243].unity.Fabian Denter. The World Begins With You  path=/Applications/TheWorldBeginsWithYou_v1.0.2_MAC.app/Contents/MacOS/TheWorldBeginsWithYou_v1.0.2_MAC flags=1

If I `chmod +x /Applications/TheWorldBeginsWithYou_v1.0.2_MAC.app/Contents/MacOS/TheWorldBeginsWithYou_v1.0.2_MAC` and then `./Applications/TheWorldBeginsWithYou_v1.0.2_MAC.app/Contents/MacOS/TheWorldBeginsWithYou_v1.0.2_MAC` at a terminal window I get this screen:

I should be able to double click on the icon rather than having to resort to terminal shenanigans to make it work.

I am having the exact same error and "Open Anyway" didn't work... Are there any solutions?

I've found it the Itch client to be a good program on my Mac. I donwloaded this game from there and launched it straight from the client with no issues at all. Works for this game and all other compatible games I've tried