Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

DragonRuby Game Toolkit

An intuitive 2D game engine. Fast, xplat, tiny, hot loaded. · By DragonRuby

Console not working...

A topic by neuronsong created 43 days ago Views: 173 Replies: 10
Viewing posts 1 to 6

I just downloaded the latest version for mac and am noticing the console is not working. Anybody else seeing this? I'll test out the windows version when I get a chance and see if it's a mac only bug.

I can confirm it's working on Linux. I've been using it all day.

I just checked the windows version. It doesn't work there either. The console comes up and goes away correctly... but no commands work inside it.

Developer

Can you provide a screen capture? If you're on Mac, you can use Kap: https://github.com/wulkano/kap

(+1)

For Mojave or later screen recording is built in.  shift-command-5 pulls it up.  Be aware this is exactly the behavior I'm seeing on Windows 10. On this Mac I'm running the Catalina 10.15 developer beta... but that doesn't seem to matter since the behavior is identical on the windows version. Here's a link to the screen capture. Let me know if you want me to try any other commands or run any code to introspect the environment.

https://neuronsong.com//_/_videos/Screen-Recording-2019-07-15-at--Jul-15--11.38....

(1 edit)

You might need to add puts to the front of the message to have it display in console. So, instead of typing:
$gtk.help
try:
puts $gtk.help

Good call. That worked. Thanks. I honestly thought I'd tried that. That is a useful workaround until it's fixed. Interestingly enough... "puts help" prints out "Type $gtk.help into the console."... which is a very python response. 

As pointed out by Brynnon... using puts as in "puts $gtk.help" works around the console issue.

Developer

We've fixed this properly in the build we just pushed, so it should work as it did before, without the workaround, now. Sorry about that!

Great! Much better. Still tells me to type $gtk.help when I forget and just type help... but I can live with that. This thread can probably go away now.

Developer

I’ll add that :-)