Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Strive for Power

Fantasy Slave Management/RPG Erotic Game · By Strive4Power

Loading error

A topic by cloakedEnigma created 11 days ago Views: 190 Replies: 8
Viewing posts 1 to 3

ver. 0.5.23b

Ubuntu 18.04.1 (Linux)

In both Story Mode and Sandbox Mode, after either selecting Quick Start, or finishing the setup after Customized Start, a loading bar will appear, but will not go past 41%.

Have you messed with any files (mods or just general manipulation)? Have you checked the command prompt that tells you what errors happen?

If you have mods, or have modified the files personally, you might have some syntax errors in the files that it can't get past. Either way, the cmd window should show what's wrong, even if you can't understand it, copy/pasting it to show what's going on would help figure out what's going on.

I've edited nothing, and I haven't seen command prompt (or Terminal, as Ubuntu calls it) show up in relation to this game.  I just right-click Strive.x86_64 and click "Run."

How do I get Terminal to behave as you've described?

when you start up strive, it should open two windows. the game and the console. The console shows background stuff like errors.

(1 edit)

All I get is the game window, and "Open with" does not provide the option to use Terminal to launch it.

Update:  I learned how to launch the game through Terminal.  These are the error codes I'm getting:

0009:fixme:exec:SHELL_execute flags ignored: 0x00000100
ERROR: _load: No loader found for resource: res://files/buttons/sexicons/rope.png
   At: core/io/resource_loader.cpp:186.
ERROR: poll: res://files/interactionpanel.tscn:12 - Parse Error: [ext_resource] referenced nonexistent resource at: res://files/buttons/sexicons/rope.png
   At: scene/resources/scene_format_text.cpp:439.
ERROR: load: Condition ' err != OK ' is true. returned: RES()
   At: core/io/resource_loader.cpp:149.
ERROR: _load: Failed loading resource: res://files/interactionpanel.tscn
   At: core/io/resource_loader.cpp:186.
ERROR: poll: Can't load dependency: res://files/interactionpanel.tscn
   At: core/io/resource_format_binary.cpp:659.
SCRIPT ERROR: _process: Invalid call. Nonexistent function 'show_error' in base 'Node (LoadScreen.gd)'.
   At: res://files/scripts/LoadScreen.gd:50.

The last one repeats many times.

I had the same error, here's console output &> errlog.txt: https://pastebin.com/JiRaxNdZ

Just search for error, it is probably easier than scrolling through the entire thing.

Oh, and I'm also running (K)Ubuntu >18 if it is important

  1. SCRIPT ERROR: _process: Invalid call. Nonexistent function 'show_error' in base 'Node (LoadScreen.gd)'.
  2.    At: res://files/scripts/LoadScreen.gd:50.

This is saying that there's an error in the LoadScreen.gd file on line 50 (the only error involving code, repeated for every time it tries to report an error, from what I can tell)), while most of the rest of the log is complaining about missing textures and images.

Have you tried re-downloading it? I don't have what you're running it on, so I'm not sure if that's the cause.

I did try to redownload it, but to no avail. Still got stuck at 41%

I did some digging in the gamefiles though, and as the log says, there is no function name show_error in either LoadScreen.gd or the Node class it extends. It seems the codeblock that throws the error is a copy/paste job gone wrong from the Godot Wiki, where show_error is included as a placeholder function.

I don't know GDScript very well though, so I'm not certain this is the case, nor how error handling should be done, and either way, this is most likely only related to actually showing the error, not fixing the cause of it.

Commenting out show_error gave me this log instead: https://pastebin.com/zLVmDrWH

I don't know what went wrong when loading the resources (And I'm not quite sure how to debug it, as I'm not familiar with godot), but interactionpanel.tscn definitely is present in my game directory, even though rope.png isn't.

Looking at the files in /files/buttons/sexicons there are no .png files at all, only *.png.import, which specify how to import the resources, but not the actual pictures themselves. Is it possibly related to this?

the .import files are fine, I only have those as well, so it's not an issue,

The only errors are in resource loader lines 149 and 186, and scene format text.cpp line 439.

Again, I don't have these errors, or the OS you're using, so I'm not a huge help, but I find that when I have errors (usually from mods) fixing one fixes others. For instance, at one point, I had like...20? or so errors (I had been trying to combine like 3 mod's files into one, since a lot of them overwrite the others, didn't work after like...a week of trying, so I gave up xP) and I couldn't find the errors being mentioned for most of them, so I found and fixed one that I could find, and boom, like, half the errors vanished.