Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Ubuntu & libtinyxml

A topic by Mighty Owlbear created Dec 15, 2018 Views: 242 Replies: 3
Viewing posts 1 to 4
(1 edit)

Hello! I come bearing a dependency error report!

I've not been able to install ProOffice Calculator on Ubuntu 18.04 due to an unfulfilled dependency.

The package installer reports the following problem:

Error: Dependency is not satisfiable: libtinyxml2-2v5 (>=2.2.0)

I have libtinyxml2.6.2v5 (2.6.2-4) installed, which I would assume meets the requirement for a version greater than 2.2.0 

Installing the 32-bit version of the latest libtinyxml2.6.2v5 library didn't help

Developer

Thanks, I think I'll fix this by baking libtinyxml2-2v5 into the executable. In the meantime, you can try installing the deb from https://packages.ubuntu.com/xenial/libtinyxml2-2v5.

Confirmed, manual installation of the dependency libtinyxml2-2v5_2.2.0-1.1ubuntu1_amd64.deb renders procalc_1.0.5-0ubuntu1_amd64.deb installable.

It's still the case that no installation package is offered through the itch.io client's install button, even after restarting the client - will recheck after next reboot.

Thank you. Now counting backwards from 10.

Developer

Oh, cool, I didn't know there was an itch.io app. I'll download it and investigate the issue.