Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

retr0virus

4
Posts
A member registered 53 days ago

Recent community posts

Ok, I tested it inside a virtual machine with Ubuntu 19.10 and there it worked. I also didn't need to install anything.

So maybe it is some kind of missing/wrong-version library in my host system (Arch Linux and Manjaro Linux usually have newer libraries than Ubuntu).

Something that you can enhance in your game: add statistics. How many deaths (maybe even why)? How many of each enemy killed? Playtime total? Maybe (if it exists) playtime per dungeon/chapter/...

This is something, where players could compete with each other ("I have been faster/without deaths/...")

With these statistics you could als implement achievements in the game (like "Monster hunter" - "Killed all enemy types", "I hate slimes!" - "Killed 1000 slimes" and so on). Achievements are a big factor for replaying a game.

But this was just a first thought about your game. I now have to enable the sound in my virtual machine to really play and test it. xD

The linux version doesn't run within wine.

I tried the windows version with and without wine and I have the same error like in the linux version (so only a black screen in the game). Maybe it really is an issue with the mono version that I use. On which system did you successfully test the linux version?

Hi, installing the "mono" package on my system helped to start the game (even with the Kick file). But unfortunately it's still not really running.

I can create a character now but when I start the game I only get a black screen. Also when changing anything in the configuration leads to a black screen even before the character generation/selection.

I tried some different start options (different LD_PRELOAD paths, start Kick, start Mystica.bin.x86, ...x86_64, Mystica.exe with or without mono) but nothing helped (but I was able to always reach the menu and get into the "black" game - sounds and music were fine and I was hearing sword sounds and so on).

So installing mono definitely helped, but not enough. ;-) Maybe you have another idea? Which mono version are you using? I have mono 6.4.0 on my system.

Thanks anyway for your quick answer!

Is there some kind of bugtracker somewhere? I tried to start the 0.8-linux demo and I was able to see a loading screen but after that it crashed  to desktop with the following error:

Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
  at Mystiqa.MapState.Render () [0x0071e] in <cc43de19fd054eae806186ce72cd45e6>:0   at Mystiqa.Master.Draw (Microsoft.Xna.Framework.GameTime gameTime) [0x00000] in <cc43de19fd054eae806186ce72cd45e6>:0   at Microsoft.Xna.Framework.Game.DoDraw (Microsoft.Xna.Framework.GameTime gameTime) [0x0001c] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.Game.Tick () [0x00239] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.SdlGamePlatform.RunLoop () [0x00021] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.Game.Run (Microsoft.Xna.Framework.GameRunBehavior runBehavior) [0x00082] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.Game.Run () [0x0000c] in <7df0491f78b541c48c6807e478b54930>:0   at Mystiqa.Program.Main () [0x0000c] in <cc43de19fd054eae806186ce72cd45e6>:0 [ERROR] FATAL UNHANDLED EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object
  at Mystiqa.MapState.Render () [0x0071e] in <cc43de19fd054eae806186ce72cd45e6>:0   at Mystiqa.Master.Draw (Microsoft.Xna.Framework.GameTime gameTime) [0x00000] in <cc43de19fd054eae806186ce72cd45e6>:0   at Microsoft.Xna.Framework.Game.DoDraw (Microsoft.Xna.Framework.GameTime gameTime) [0x0001c] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.Game.Tick () [0x00239] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.SdlGamePlatform.RunLoop () [0x00021] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.Game.Run (Microsoft.Xna.Framework.GameRunBehavior runBehavior) [0x00082] in <7df0491f78b541c48c6807e478b54930>:0   at Microsoft.Xna.Framework.Game.Run () [0x0000c] in <7df0491f78b541c48c6807e478b54930>:0   at Mystiqa.Program.Main () [0x0000c] in <cc43de19fd054eae806186ce72cd45e6>:0

I am running on a Manjaro Linux with the 5.6.2-1 kernel and the open source amdgpu driver.