Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

MinaMina

2
Posts
A member registered Nov 26, 2016 · View creator page →

Recent community posts

The developers said:

Sorry but this game is not supported by your device. We sincerely Regret that you are experiencing issues.

OpenGL 2.0 or higher with the FBO extension is required. OpenGl version: 1.4.0 -Build 8.14.10.2108

Type:OpenGL

Version:1:4:0

Vendor:Intel

Renderer:Intel Pineview Platform

Please update your graphics drivers and try again.

Love,

The Developers

(What should i do with this? I'm too excited to wait it download finish and then this came out..pls help me with this. Thank you. And btw im from Malaysia! <3)

I love this game so much! Great graphics and a great game too! <3