Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

LadySalamander

1
Posts
2
Topics
A member registered 36 days ago

Recent community posts

I'm trying to figure out how to render the sprites in the save file manually with the end goal of just moving them over so I can have two columns of save files, I'm new to scripting and it's driving me bonkers.


I'm trying to grab the static sprite image like in the default, nothing moving or anything fancy like that. I'm sure I'm on the right track with this but, I have no idea what lunatic type to ask for.  Type character was my first guess but it comes back with the error unsupported, image obviously just looks for an image, type grid doesn't throw any errors, but it doesn't display any characters either. .... and that's where my knowledge runs out lol. I tried a workaround wherein I just called an image of the character saved in the system folder, but because I wanted it to reflect the party formation it fails on the load screen because well, there is no party formation yet. It also unfortunately changes the images in EVERY save file, regardless of the data saved there. I'll post an image of that too, just in case.


It's odd to me because the "data" condition in this case is getting the time properly and the map name properly, but hey, what do I know.

The only plugin I have that directly affects the save files is LunaSaveFileAdjust. Any advice is appreciated!

Forgot to mention I am using Yanfly Battle Core and Luna battler.

First problem is solved! But the image described in the lunatic still moves of its own accord if anyone has any insight

Hello! I've been having some trouble with Luna and SceneBattle.

So first off here is a quick example of the layout we are going for:



My first problem is the ActorCommand sticky. Is there a way to turn it off? Even if I set the setting in general to default it sticks to the corner and I can't move it. Right now I'm just relying on a massive contents offset which doesn't feel good.

This may be related to my second problem, which is that when I add ActorCommand and PartyCommand to the layout (it's just a generic Free Layout) the formatting gets destroyed. Most notably it 1) moves drastically (maybe because it's no longer stuck?) and 2) the two columns get converted into one long line. And yeah, it works great and it's functional and visible when it's not in the layout, which is ... quite the opposite of what I've encountered using Luna Engine so far. (everything here applies to PartyCommand as well)




The third problem is BearMan there. I added him in as an image element of ActorCommand in the lunatic. The image changes depending on whose “turn” it is, and calling the image is working great. The issues are 1) I would like to have him behind BattleStatus, hence why I need to add Actor Command to the layout, and 2) the image changes position for each actor, even though the actor command menu stays still. Even if I have the same image labelled 0-5, they will all appear in different places. I thought this might have something to do with the battle being in the side view and it still snapping to the battle sprites, but I tried switching to the front view and it didn't make a difference, the image still moved. The final version will be using side view mode.

Here's what it looks like in the lunatic:


Anything I put in here also seemed ... less behooven to the contents offset (maybe because ActorCommand isn't in the layout?)

To sum up my questions are; Why is ActorCommand behaving like this and how do I get it to stop and (actually most importantly) Why is the character portrait moving and how do I get it to stand still?

I'm very stumped; any insight is welcome. Thanks in advance!