🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

bratmoi

2
Posts
1
Following
A member registered 177 days ago

Recent community posts

hiscore: 1451

yay, i'm on top of the leaderboard :D

(Edited 1 time)

The Linux build is compiled for x86/32 bit. Therefore you need 32bit libraries, in Fedora 25 x86_64/64bit this worked for me:

Manual recipe:

  1. List dynamically loaded libraries the game needs with $ ldd GodspeedMankind | grep 'not found'
  2. for each line of output
    1. Find out name of existing 64bit library with $ find /usr -iname libXcursor.so.1 -print -exec rpm -qf {} \;
    2. Install the 32bit/i686 architecture package by $ sudo dnf install package-name.i686
  3. With my preexisting install, i just needed to run $ sudo dnf install {libglvnd-glx,libXcursor,pulseaudio-libs,mesa-dri-drivers}.i686

Here's the comprehensive list of packages the game works with on 2017-04-25 (useful for fresh OS installs):

$ ldd GodspeedMankind | egrep -o "/[^ ]+" | xargs rpm -qf | sort | uniq

alsa-lib-1.1.1-2.fc25.i686
dbus-libs-1.11.12-1.fc25.i686
flac-libs-1.3.2-1.fc25.i686
glibc-2.24-4.fc25.i686
gsm-1.0.16-1.fc25.i686
libasyncns-0.8-10.fc24.i686
libbsd-0.8.3-1.fc25.i686
libcap-2.25-2.fc25.i686
libgcc-6.3.1-1.fc25.i686
libgcrypt-1.6.6-1.fc25.i686
libglvnd-0.2.999-14.20170308git8e6e102.fc25.i686
libglvnd-glx-0.2.999-14.20170308git8e6e102.fc25.i686
libgpg-error-1.24-1.fc25.i686
libICE-1.0.9-8.fc25.i686
libogg-1.3.2-5.fc24.i686
libselinux-2.5-13.fc25.i686
libSM-1.2.2-4.fc24.i686
libsndfile-1.0.28-1.fc25.i686
libuuid-2.28.2-2.fc25.i686
libvorbis-1.3.5-1.fc25.i686
libX11-1.6.4-4.fc25.i686
libXau-1.0.8-6.fc24.i686
libxcb-1.12-1.fc25.i686
libXcursor-1.1.14-6.fc24.i686
libXext-1.3.3-4.fc24.i686
libXfixes-5.0.3-1.fc25.i686
libXi-1.7.9-1.fc25.i686
libXinerama-1.1.3-6.fc24.i686
libXrandr-1.5.1-1.fc25.i686
libXrender-0.9.10-1.fc25.i686
libXtst-1.2.3-1.fc25.i686
lz4-1.7.5-1.fc25.i686
pcre-8.40-6.fc25.i686
pulseaudio-libs-10.0-2.fc25.i686
systemd-libs-231-14.fc25.i686
tcp_wrappers-libs-7.6-83.fc25.i686
xz-libs-5.2.2-2.fc24.i686

mesa-dri-drivers.i686 # not a direct dependency of the game but without it you get "libGL error: unable to load driver"