Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

On Ubuntu 15.10 (should work on 14.04) I had to:

sudo apt install libxrandr2:i386 libxcursor1:i386 libglu1-mesa:i386

Oh and you may have to run:

sudo dpkg --add-architecture i386

first