Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Related (For 64 bits Manjaro users)

Besides AUR's lib32-libnotify there are some other packages that need to be installed too:

lib32-gtk3 (removing lib32-gtk3-classic)
lib32-nss
lib32-gconf

I think that's enough to pull the dependency chain necessary for running this game. If not, just read console output then ask for help. :)