Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

It's hard to say what it is, but my guess is that your video card might not support OpenGL 2.1 or newer. The minimum spec is: Intel HD Graphics, GeForce 6xxx, Radeon HD 2xxx. If you do have a card from those series or more recent, then maybe you could try making sure you have the latest graphic drivers?