Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Hi, thanks for trying our game, I'm sorry that you weren't able to launch it. The itch client currently does not support LÖVE2D games, that issue can be tracked here: https://github.com/itchio/itch/issues/135.

The game requires LÖVE version 0.10.1, it will not work on any version of LÖVE 11.x. If you provide me with further details, I can assist you further.