Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

"Some required 32-bit libraries are missing: libnss3.so"

I have the libnss3 package installed...