🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Update check won't let me play the game.

Tried re-downloading, disabling firewall and antivirus, and running as an administrator.

Could you check if the message pops up when it can't connect to the update-checking server? because for some reason itch app can't establish the connection as well.

Thank you in advance.

Could you let me know what version it says in the bottom right? It should be 0.1.7a

In the Itch App, if you go to the Library tab, and click on the image for LMS, there should be a button that says 'Check for update' near the bottom-right. If you click that, and it says it's up to date, then I'll have to figure it out.

If it's not working properly after being up to date, I'll probably add a 'bypass' button, so you can still try to play (though playing with different versions will probably not work).

Thank you for your kind reply. I've checked those two things you've told me.

I made sure that everything is up to date, to the version of 0.1.7a, but the message still pops up.

One of my friend is experiencing exact same issue as well. Sorry for making trouble but it'd be great to have a 'bypass' button. It's too bad that I cannot enjoy your game yet, but thank you for the game though.

(+1)

There'll be a new update soon with a bypass button. Just finishing up some extra features before making it available.

Though, whatever's preventing you from getting past the version check might still cause issues with connecting... I guess we'll find out!