Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags
(+1)

Ok, so, no surprize at all here, the game requires OpenGL 3.2 at least. You may want to put this as a minimum requirement.

Works rather well with software rendering on a mobile 1st gen i5 though, apart from occasional hang-ups and fps drops in menu, as well as when rendering shadows or many sprites.

Testing will continue when I get to my actual computer.