Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

you actually need an extremely old version of mac to play it on mac lmao

I think it's because apple doesn't want to update OpenGL or something.