Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

This is beyond irritating [error: unexpected the]

A topic by Devious_Oatmeal created 7 days ago Views: 55 Replies: 3
Viewing posts 1 to 4

This is what I type:

"butler push Isle of the Crown (Itch).zip devious-oatmeal/isle-of-the-crown:win"

And I only keep getting the error [error: unexpected the]

I've also tried putting in the complete directory, but I still get an error that's similar. [error: unexpected "word"]
And it also gives me the help, so I am sure the initial setup is good. I just don't know why it won't take that as a command.

I also tried:

butler push Isle-of-the-Crown-(Itch).zip devious-oatmeal/isle-of-the-crown:win [error: file can't be found]

(+3)

The problem with the first command you shared is the spaces in the filename, as you seem to have noticed (based on your second command).

On the second command, I think the issue might be having the parenthesis in the filename, which might confuse a terminal command. Did you make sure to rename the file itself before running that command?

Could you try the same command, but surrounding the filename with quotes (”)? These will make sure to wrap all characters into one command argument, regardless if it has spaces or other special characters.

Also, just to confirm, when opening the command line, are you at the same directory where the file is located?

Admin(+1)

It’s always safe to warp arguments in quotes to avoid any issues.

The spaces is what was causing the issue, which was my guess but I had no way of knowing for sure- which you mentioned Dark. It also explains why I was getting an error in an even earlier part of the directory when I was trying different methods.

But yeah. It went through on the first try with the quotes and the full directory without having to change anything.

I don't know if y'all have a way of letting them know, but as someone that has never really messed with command lines, the quotes thing should definitely be in the documentation. Basically what Dark said, but maybe with that empty bullet point, right after [directory], like the examples.

Thank you both though!