Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Wild Woods

Go on an expedition, cooperate with up to four friends and fight your way through the woods · By WildWoods, TheBuergermeister, nadjacl, _Jar, Ruhken

EXE deleting itself on exit? What sorcery?

A topic by CuriousQuail created 23 days ago Views: 134 Replies: 3
Viewing posts 1 to 3

Hey y’all! 
Absolutey loving the game, but I had a few issues getting my controllers to sync (seems like if you have direct input and xinput connected the former cancels out the latter) and had to quit / restart the game a few times to get it right…but every time I exit the game, the .exe goes missing from the game’s directory! 


It’s the wildest thing, I’ve never seen anything like it. I can re-copy it over from the zip but any ideas why it might do this? 

Again - love the game. The co-op is INCREDIBLE. 

Developer

Hi there, this sounds really weird and should not be the case. Any of it ^^

To get an idea what is going wrong here, please answer me a few questions:
What version of Wild Woods are you using?
What System do you run it on - Windows?
What Kind of Controllers did you use?
Where did you executed the .exe from? Desktop folder? OS Harddrive?
Where there any complains of you anti virus software or "not trustworthy software" warning from your OS ?

Eric from the Wild Woods :-)

Hey Eric! Sorry for not including this earlier! 

Version: 0.016a for Windows
OS: Windows 10 and Windows 7 (tried on two machines cuz I was losing my mind lol) 
Controllers: Tried a myriad - Hyperkin SNES USB, Xbox360, WiiU via a mayflash USB adapter, even tried adding the game to Steam and using Steam Controllers as Xinputs. In all cases, the controllers worked so long as there wasn't both Directinput AND Xinput devices connected (in which case, only the DirectInputs would work)
EXE: On both devices, launched EXE from a Games\subfolder on a non-OS drive. Gonna try an OS drive Program Files\ test right now. 
AV: Have AVG on both devices but saw zero warnings of any kind and the files aren't being tossed in quarantine (checked that first). 

In every instance, the game runs great but as soon as I exit, the .exe vanishes from the folder. All the other files remain. Also, it's not ending up in the recycle bin either. 

Otherwise, seriously can't sing the game's praise enough! It's so much fun, and I can't wait to see where it goes!

<3 

Developer (1 edit)

This is super weird.
I am absolutly stunned by the fact that a file can be vanished by ending a program.
Let me talk to our programmer and do some research. Right now i have no clue how this could happen.
Comming back with new informations soon...

Eric

(Alternativly join our discord, some of our catlovers already found solutions to weird problems like yours, maybe someone there is faster than us or has an idea. - http://discord.wildwoodsgame.com/ )