Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Make your Adventure

Turn your idea into your video game, even without programing skills. Just Make, Share & Play · By Lanyu EStudio

How do you open it up

A topic by DarrenBOK created Jun 11, 2020 Views: 186 Replies: 11
Viewing posts 1 to 6

Theres a folder that say data

Then Creacion.jar

then Juego.jar

How do you start the programme?

If you have Java installed, you can just double-click Juego.jar to start the game or Creacion.jar to start the editor

If you don't have Java installed, you need it.

Developer (1 edit)

Hi, thanks for your interest!
What is your OS?
In windows just do what blue lander games said.
Don’t hesitate to ask me if you have any problem.

I have installed java and when I open the program it opens then immediately closes. Really disappointing as I was looking forward to trying it out. :(


Hi, I asked for your OS. I only tried it on Windows and using app and works fine. Do you have Mac or Linux? If you can tell me I could debug it. Also you can open a terminal and execute with “java -jar Juego.jar” so you can copy the output and paste here the log.

(1 edit)

I think I found the problem.

I ran the jar files through the terminal.

Lanyu EStudio forgot to set the default class in the jar files' metainf files.

And that entry in its metainf is how Java knows which class to start it with when you open .jar file on its own.

I am on windows and downloaded this through my normal web browser.

I will let you know if running through the app makes a difference.

Edit: Nope, no difference

Wait...that's weird.

They did set the def class....

But then why is Java not seeing it?


Could you send me the log you get in the terminal and tell me what operating system do you use apart from windows?

Thank you!

(3 edits)

Running "java -jar Creacion.jar" from command line.

    Running Creacion.jar directly

    • Nothing.

    Running "java -jar Juego.jar" from command line.

      • Hangs for several seconds.
      • Hanging for several seconds on a blank window with the title "Tu Propia Adventura".
      • Window then closes, and this error log.
      • Last time I tried it all it did was the error log, but no window.

      Running Juego.jar directly

      • Nothing, not even the window mentioned above.
      Developer (1 edit)

      MYA use relative path so you have to execute with java from the folder containing the .jar files (which also contains data folder).

      First, change working directory:
      cd D:\\Files\Apps\make-your-adventure

      Then open with java:
      java -jar Juego.jar

      Same steps for Creacion.jar

      If you have no luck send me the log.

      Thanks for this useful information! We will make it easier to run the game and the editor to avoid these problems.