Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Problem with moon and sun light, fps drop with foliage

A topic by OldFoxNorth created Jan 28, 2020 Views: 75 Replies: 4
Viewing posts 1 to 5
(1 edit)

Hi, I’m sorry to disturb you. There are several problems.

In light sources (sun and moon), their reflection on the water flickers. And the frame drops per second when foliage is on. 

Eras II

I use 10 win, but tried clean win7 and used different versions of DirectX and tried to change the settings, drivers, the result did not change

Thank you (sorry for my english)

(+1)

I was able to reduce the reflection flicker some.  The actual sun in the sky still flickers quite a bit, though I tried to reduce that too.  Part of the problem is the original design of the "sun flares" and "overflow" features they used are put in a loop that doesn't always execute every loop iteration because if they execute every  time, they greatly reduce the framerate.  So I think they decided they wanted the features to provide some dynamic effect of the sun rays and those "rainbow" type flares, but tried to reduce the impact of the performance hit they cause.  I do not intend to rewrite the whole thing, but I did try some changes to reduce the problem.  Update the newest Maelstrom engine from today's update and see if it helps.

The foliage does cause some performance problems and they did provide an option to reduce the impact.  Under Options, there are checkboxes to change the Foliage Quality.  You can choose None, Low, Medium and High; the higher quality means more of them draw and can cause framerate drop, while Low will draw fewer of them.  I do not know enough DirectX to improve the graphical calculations and shading programs to allow higher quality without an FPS drop, so the options to simply reduce the amount of foliage, or remove it with None are the only options right now.

(+1)

I just found some superfluous grass render code that executes, but actually had zero effect because it set a bunch of render states, then immediately set them all back without anything in between that would use those render settings, so it essentially did nothing for benefit.  This could contribute to some degree of slowness in DirectX, so I removed that useless part of the code.

Ok, I'll try it today

I saw that now the flicker is smoother and not so noticeable. In any case, it no longer hurts the eyes. 

Thanks)

I think the problem is with modern hardware. Because I tried on win10 with the latest drivers and forced DirectX on and on win7 I tried to install older drivers  or maybe not 

Perhaps if you need here are my components:

https://drive.google.com/file/d/1uiDJKYRUYqtc9SI2O6uBk7NgOnZKRlYO/view?usp=shari...