🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bug reporting Sticky

A topic by Dr. Whoop created 245 days ago Views: 997 Replies: 30
Viewing posts 1 to 15
Developer (Edited 21 times)

Known issues:

  • Major
    • Camera does not deal well with furniture
    • Furniture has no collisions, and some pieces do not line up well with track
    • Only certain types of track can currently be selected
    • You can't undo after placing a special piece (junctions, crossings)
  • Minor
    • Going slowly over a hill can cause some clipping
    • Attempting to turn too late into a junction which has no piece attached to it's straight section can cause problems
    • You sometimes get inappropriate track choices in build mode after reversing your direction
    • Resolution scale option sometimes refuses to change, switching fullscreen mode on/off fixes this.
    • Menu buttons sometimes wrongly remain highlighted
    • Clear Track leaves behind some pieces - You should still be able to delete them with right click

Planned features which are not currently available:

  • Environments and proper object collision
  • More extensive options & graphics menu
  • Track saving/loading
  • Sound, music and UI improvements
  • Carriages
  • Objectives, weight mechanics.

Game will not download.


Can you explain a little more?

If you click the 'Download now' button, click 'No thanks, just take me to the downloads' and you should have the option to download the 32bit or 64bit version

Please add carriages soon, I want to build a huge train!

I can't open the game, when i double click on TrainSet.exe it says,

"The procedure entry point abort coud not be located in the dynamic link library C:\WINDOWS\SYSTEM32\VCRUNTIME.dll."

Any ideas on how to fix this would be really helpful. I really look forward to playing your game!


Could you double check if it says 'VCRUNTIME.dll' or VCRUNTIME140.dll'?

Maybe this thread will help: https://answers.unrealengine.com/questions/354251/...

Double checked, it's VCRUNTIME140.dll

Sometimes when I click 'Clear track' it doesn't clear some special pieces


Thanks! I have found the issue and it'll be fixed in the next version.

Furniture doesnt load on saves

You have to load it separately as environment

My computer is really slow so that may be the only issue, but if my graphics or resolution is too high, the train will not turn, but keeps going. Also, it is always like a few feet off of the track

also wanted to verify, it is only off of the track if the graphics or resolution is too high



Looks like the problem happens if the framerate is very low, I'll see what I can do.

Thanks, it could just be my computer but i've never seen a game do that


Very low/high framerates can do all sorts of strange things in games, it's just a bit more obvious here.

If you're interested: The way the train works is that it gradually builds a path to follow as it moves. Every frame, it checks if it needs to build a little bit more of the path. (A gif from early in development showing this process)

When the framerate is really low, this checking doesn't happen often enough and the train basically moves faster than it is building the path, so it glitches out.

It's just a visual thing and should fix itself when the framerate goes back to 15+. I've also fixed it properly for the next version.

Deleted post

Where do you see it is set to inf?

If you go to the game folder, TrainSet > Saved and delete the 'Config' folder, that should reset all the graphics settings to default, hopefully that fixes whatever is wrong.

I know i deleted this post but whatever (i did not read the known bugs list)

the inf is in GameUserSettings.ini

I have an issue with the 32-bit version saying that it's not a valid Win32 application

I haven't tried moving it to my 64-bit laptop to see if it works there, but I can't open it on my 32-bit one


Hmm, I'm not sure.

If anyone else has this problem and managed to fix it I'd love to know how, I can't really help without more information.

Game Crashes upon pressing "Play"

As the title says; as soon as press the play button the game freezes and then instantly tabs me out and becomes unresponsive. I was running Fraps when I very first ran the game but I closed it as soon as it alerted me to the possibility of an error and I haven't had it open since.

Any help would be appreciated, as from the footage i've seen this game really encompasses my childhood passion.


That's strange. I don't think Fraps should really cause any lasting issues.

Maybe you could try deleting the game files and un-zipping a fresh copy?

https://puu.sh/vQKSg/ad3de8b877.png @Dr Whoop

Thanks for the advice, I gave that a try but the game still crashed. This time it gave me the error (which I have linked above).

Any help would be greatly appriciated.

If you make the train do a jump, and go backwards in midair, it starts to go upwards....


Heh, yeah. I like it but I should probably fix that.

I think it won't turn if you are going too fast?

im not sure if its only me but placing peices can be really fiddley because when i need to get peices to be in the correct position and direction it is sometimes impossible! and because there is only a limited amount of junctions getting the track to send the train the correct way. no dis here it is a great game just some things like better junctions and track directions need to be fixed. ive attached my save file so you can see what i have made and in the section i really struggled what i have done (the bit with the random uncoplete junctions). great game and keep going with all the work! best wishes SuperNinja this will take you to media fire to download my save file



Thanks very much for taking the time to upload your save file, I really appreciate it.

I agree junctions can be a little awkward, I already have some new ones for my internal build and will add as many as I can see a use for. Definitely doesn't help that you can only currently select/edit straight and turn pieces, that's something that should make things easier when I sort it out.

thanks. Loving the game!

You can delete the track while the train is running and it will fly off the side of the map, crashing the game eventually...

Could not make the train go up hill by using F.