🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bugs/issues on demp. Sticky

A topic by Dεмøη created 275 days ago Views: 32,043 Replies: 108
Viewing posts 1 to 69
Developer (Edited 6 times) (+2)

Topic where you can report bugs/issues with demp


Make sure that the problem is not described in the FAQ.


For the description of your problem, attach output_log.txt


  • How can I send a file output_log.txt?
  • Where is the file located output_log.txt?
      • It is located in the folder Vx.xx_Raft_Winxx. For example V1.05 Raft_Win64.

i have an issue where i am not able to connect to my brothers world even though we are right next to each other. pls help thanks

Developer(+1)

So, how you tried to connect with brother? I mean, hamachi? lan? external ip?

i tried through the lan system on the mod

how do you chose a world to host cuz every time it generates a new one

Developer

At the time loading world is not available. I will add this soon.

Do you have an estimated time on when you will be able to load a saved world?

Developer

From version v1.02b of modification, this option has already been added.

Deleted post

Im using the version 1.02c but I can`t select the saved world.

Hi

I tried the multiplayer yesterday and it worked for me and my friend, the only strange things that i found were the food and drinking hat i made weren't available for my friends. Is this the intention or will this get fixed?Also after i saved the game and reloaded it 50% of my base was just gone. I Lost 50%of my progress.

Also do you know a solution for the fact that the game is crashing at a point when you're playing? Like i'm just playing and all of a sudden the game freezes and doesn't respond anymore. Therefor i lose all my stuff that i've made.

Developer

Saving the game and greater synchronization will soon be added. Crashes of the game, from what I know normal raft have this issue too. But for sure you can send me output_log folder V1.04_Raft_Win64_Data. Then I will can confirm that is the modification crashes or not.

How can i add a folder here to send it to you?

Developer (Edited 1 time)

Upload this to site like mega.nz or mediafire Generally wherever you want.

(Edited 1 time)

https://mega.nz/#!FkpHySyb!NH1HHKbMDLykl5ig0zrw0hJ5b5GW5Gla5NckKZexs8Q i think this is it

Developer

You sent me an entire folder with the game xD But you have to send only the .txt files like i said. Anyway i just download it.

oh sh*t sorry :p

How do I adjust my sensitivty? Your game is currently unplayable for me with a 360 - 1cm.

Developer

Sensitivity/mouse staff are not mine. It's game issue, try to change mouse sensitivity from your mouse software or system settings.

How to install on win32? I'm extracting this mod and copy to the game folder. After i'm changing name folder to V1.04_Raft_Win32_Data.

If i'm running game mod doesn't run. Sorry for my English, im from French

Developer

You got any information about replying files in a folder V1.04_Raft_Win32_Data.?
If not just move all content from my folder V1.04_Raft_Win64_Data to your folder V1.04_Raft_Win32_Data. You have to overwrite all files..

Me and my Friend played the Game yesterday. Great Job!

we found this bugs:

- i could pick up Infinity resources it didnt disapear after pressing E on it

- also after a disconnect you cant rejoin the game (without save-game this is sad because you have to start from new everytime)

- sometime when you throw the rope there are random Fake barrels in the Air/Water

Developer

I have heard somewhere about these errors, thanks for the confirmation! I will try to fix them in the next update, but the main novelty will be loading the game save :)

Hello, when we play some time and build and then press Main Menu (Save Game) and name it: test . I have a dempSave file which is the save game test but with another name. And i can only load it in Singleplayer. When i Host a Server and want to chose a Savegame there is none. So we have to start new everytime.

(Edited 1 time)

HEELP ME!!! Long Join the server. I waited an hour and nothing.

i have downloaded it but when it says to open it i open it in internet explorer and im pretty sure thats wrong what do i open it in. please help

I downloaded it but I have a 32 bit computer. The file says 64 bit. So how do I install it?

(Edited 1 time)

I've got an issue with the mod. When I installed it, I wasn't able to pick anything from the item nets. I probably installed something not properly, but I don't know for sure. I have a 32-bit system, if that changes anything.

Developer(+1)

In version v1.02b bug with net got fixed.

Thanks!

i still got the problem in 1.05

Deleted post

me too please help i dont think im doing something right cause when i open the file it just brings up internet explorer and then the open or save thing and when i click open it bring that back up. PLEASE HELP!! i really wanna try the mod and give feedback and play with my friend so please help!

(+1)

No, i meant when i download it it downloads a file instead of folder....

Developer(+1)

Do you have a program that's called WinRAR?

(Edited 1 time) (+1)

No, XD i thought you just downloaded it... why, do i need it to unzip files? (I already can unzip files though)

does 7zip work

yyes

I would really appreciate if you made a complete tutorial on youtube or something like that that shows everything because i am having problems with this please do this it would make it alot easier

if someone could make a complete video of everything you need to do like downloading it on camera and showing me or if i could get some 1 on 1 help that would be the best!

Attention Everybody who needs help downloading it! You have to have winrar like you MUST have winrar to install it.

everything is working but i can not load a saved world. it would give me the option to select a saved world. however, none of my saves would show up. i have 4 different rafts already saved so the rafts are there i just cant select them. im on the latest version for both the mod and the game.

It just says "save to load is not selected"

Developer

You can only load saves that were saved by:


Mountain View

oh my god im so blind lol.... thank you

i join a server but it doesn't work didn't do anything wrong

Developer (Edited 1 time)

You join the server.. So what's the problem?

ok i have winrar but what do i open the download in when i download the mod

Developer

Right click on the .rar file and extract?

i dont get a .rar file do you have skype i could send you like a picture of what i mean

(Edited 1 time)

every time i try to join a server i get this https://mega.nz/#!8VpyHRrY!wlWCCe4hSsmnxU6Rr8tfVU86PGCzLltACOBKcIETnPk then i get this https://mega.nz/#!lERAATCY!WlQiXmlHwuLij9w7Idq7JLjfa7WIGduMxL0R7QF3HWE pls help me

Developer

"Continue" button.

i do and it comes up with the other picture i tried multiple times

it finally worked

I downloaded 1.04 version of Raft and after a while i saw that you can play multiplayer so i thought why not?I went to downloads, i downloaded 1.04 Demp i copied the files to the game file and started the game.It worked but i couldn't play because everyone had 1.02c for 1.05 version of the game but i had 1.02b for 1.04 version of the game..I unistalled 1.04 version and went over to download 1.05 but it is for 64-bit only and i couldn't get it work because i have 32-bit and i was like okay no problem i'll tell my friend to play on 1.04 but when i downloaded 1.04 again and did the same again it didn't work... Any solutions?


~Thanks.

Hello, i am playing the multiplayer version, but on singleplayer till my friend joins and i seem to have a problem with collecting items in nets. It says press e and i press it and nothing happens. It may be the game its self but it wont let me collect any items. I made other nets to try and still nothing

(Edited 1 time) (+1)

1. Models and items not moving

Everything is not moving from their positions; the shark, other player, or items in the water. However, their models are: The shark is still 'swimming' but is frozen in place. The other player's model can be seen walking, but is also frozen in place. The only thing that seems to be moving normally are the plants and trees growing, smoke particles, the sea and the Sun and Moon. The game seems to be running smoothly around ~60 FPS. I am running the game on the highest settings.

2. Items disappearing from server after quitting

Items disappear after quitting and returning: Water cans being purified and fish being cooked disappear after resuming the server. Items in chests and the player's inventory disappear as well. Additionally, plants and trees disappear, whether they'd be growing or fully grown.

3. Items cannot be pulled back (might be related to 1st point)

When I try to pull back items in the sea, items that get caught in the hook start to 'spazz out' and won't be able to be pulled back. Additionally, the game thinks that the hook has caught something and at the it doesn't at the same time: I'm able to switch to other items in my hotbar. This causes my the items which are caught in the hook to disappear:

(Click on images for larger picture)

However, when I use my hook again, I'm unable to right click to retrieve it back because the game thinks that there is still items caught by it.

Additional information:

  • Edition: Windows 10 Pro
  • Processor: Intel(R) Core(TM) i5-3570K CPU @3.40GHz 3.80GHz
  • Installed RAM: 8.00GB
  • System Type: 64-bit operating system, x64-based processor
  • Version of Game: 1.05


Thank you for the effort you've put into making this mod. (:

Developer(+1)

1 and 3, it looks like a bug. You can send me the file output_log.txt then I could check these errors. 2 is just the my fault, that these things had not yet synchronized.

Dεмøη, I cant install the mod. I overwrite the stuff, launch the game, and nothing

Help me please


I'm sorry, where can I find the file output_log.txt?

Developer

in V1.05_Raft_Win64

Hello guy, my friend does not come at all to play there in 32 bits, I nevertheless try everything .. help me: p

we cant pick up item

i cant connect to my friend and he cant connect to me. we tried a ton of times using different settings too.

I was using the /give command and I couldn't find wood planks ? I tried every number from 1-30 but it wasn't there ?

Developer

Plank = 0

I can't connect with a my friend togheter on a server without NAT.

Pls resolve this bug fast!

Developer

It is not bug, you and your friend just doing something wrong or yours connection does not allow to host/connect.

Hello i have problem with multiplayer when we done to play with friend and i trying to save the world its saying wait saving the game bla bla bla and we waited alot of time but still cant save game pls help?

So I have downloaded Raft for Windows 64 Bit v1.05, and I installed Demp V1.02c for 1.05 and every time I install it I don't get any GUI on the main menu so I cant play at all. Any Ideas? I extracted the files into my raft folder and replaced the ones it said already existed, as per the instructions.Thanks!

Hi, so I put all the files in the game launcher folder (and replaced the data folder) but when I try to launch it it says that the folder "V1.5_Raft_Win32_Data" needs to be next to the exe file, BUT IT IS...THE FOLDER FROM THE RAR FILE IS THE SAME NAME!

wut it happening?????

(+1)

When you replaced the data folder did you replace the whole folder? If so you only need to replace the managed folder inside the Data folder.

(+1)

I was hosting a game with a friend online, It was fine for about an hour and 15 minutes, then i started getting errors for item loads, and then i couldn't pick up coconuts, then I realised no items where coming except some barrels, and the only way i was able to collect things was through nets when items would randomly appear in them, then as i proceeded to craft some rope the game froze and stopped responding.

The Shark ate our entire raft. We had three parts left of the raft and the Shark eats it all. Is that supposed to be like that?

I am getting an error when playing with my friends, with 2 players it does not show up. but with 3 players it shows up.

Error: TagPlankAsDragged

Error: CollectPlank

I am getting the same errors with 3 players. 2 players is fine.

Im getting an error after a few minutes of playing with a friend (only us 2) which says "ERROR: TagPlankAsDragged" and then "ERROR: CollectPlank" in red writing. How do I resolve this and if there isnt any way, please look into fixing this because the game is unplayable like it thanks guys :)

So when a friend tried to join it had said for them that the NAT needed to be put on, but on my side it had been on. Is that a bug that's been old, or is it new, a fix would be great, or something that needs to be done every time, someone wants to join, second for the first couple of minutes of game play, sharks when they would attack the raft wouldn't once in awhile would not actually show they were biting, and when I dropped items they other player couldn't see them.. Thanks, reply when you have time, you're working very hard, take you're time!

ERROR: TagPlankAsDragged and ERROR: CollectPlank really does break the game. It's unplayable until this is fixed. Any update on this?

When I play with my brother,We just can't get anything from the ocean.When we drag something back,it just disappear.Please teach me how to.Thanks!


There's a bug. When i played with my friend a shark started to attack our raft. It showed to me like its just not moving to my friend he said its attacking. It was a problem...

Yeah thats happening because the shark is not synched with the host and client so that means each of you will se the shark in different possitions.

Sometimes there is fake barrels... Also when i played with my friend a shark started attacking our raft it showed to my friend but not me....... Please reply or fix the bug. Thanks.

yeah because the shark is per player ,not synched to all players that mean you see a sahrk in different stage than your friend does

We played a 5-man game, a couple of sharks attacked and the block destroyed varied by player (two players saw the water purifier, two saw it destroyed).

This continued to happen and everyone was just seeing entirely different versions of the raft.

Also, we were finding that it was extremely difficult to build the raft out enough to protect it from sharks which proceeded to frequently destroy our core resources. We think part of the problem was that although we had 5 players, it didn't feel like the number of resources was multiplied at all, so it was just a lot harder than single player.

man i just said that the shark is not syncronized to clients from the host , that means each client see different shark positions or gestures.

After copied the files of the multiplayer co-op mod cannot play single player!! please HELP!! Version-V1.5

Server Version V1.2

Developer

If you want to play single player you have to make other version without mod. (At the moment)

hi i had a bug with me and my friend.when he hosted the server then he couldn't pick up items floating on the water (if he hooked he didn't get items aswell). then when i hosted the same happend to me :/. plz help

(Edited 1 time)

- After 1 hour playing with my friend we were not able to pick up coconut anymore.

- Half of my chest had the same inventory with me and my friend. The other half was 2 different chest for me and my friend.


Sorry for my english i speek french

Hi, my friends can't join my server. Why?

I downloaded the multiplayer mod of raft 1.05 and ı saved game and ı quited and ı open the game again but my goods was deleted

(+1)

We played on a server. Then we saved it. And then later we loaded it, it was all right, but we couldn't pick up items with hook, or hand. We could only use nets. We also couldn't pick up coconuts.

Thanks! :)

(+1)

HI! I am Norman from Hong Kong,It was a very nice survival game, but I am sorry to tell you that the raft multiplayer cannot save sometimes, when i clicked save after playing 30 mins with my friend, it stucks on the sentence of " Saving the game" . I really hope that it can be fixed, thank you so much.

Hi, I have a Problem with the game. If I am trying to load a savegame with much Content and much Things in the inventory or much Things there are bought then the game stucks and crashs. I am in the loading screnn but just in this Moment the game had chrashed any time. So I hope this bug will be fixed next days. Sry for bad english!

Paul :)

I just made a reply about that topic, saves not saving and crashing, not mentioning the crash part tho. I hope our's will be noticed ;)

pls how can i open my world i dont want to start always on new world

?

in the host lobby click the "Select save" button (sor 4 poor english)

If i go on another persons game i cant pick up anything it says error

(Edited 1 time)

How to update?

And if you play multiplayer and cook water. you reread game. Then your water cup will be disappear.

(+1)

So i was trying to connect to my friends server and then it loads somekind bug i can't connect to my friends server it just appears somekind of 17 server and thats it it  doesn't load the server i can't  connect...

how can i play my singleplayer map? -.- i think i lost it for addind this multiplayer mod

So I've stumbled upon yet another save issue, ( I've seen changelog fixing them...) so I wanted to quickly express them.

When you finally connect and start a game with a friend, after playing for a while you get bored and want to exit out and save, right?

Well I tried that and the save kept saying that it was saving, gathering data, it could take a while, you get the idea. (Absoluteley nothing happened) 

I hope this explained and that you can fix this ASAP

we play together and all but the player i play with freezes forever pretty much from the beginning. they can't even see my messages i send them telling them they are freezing, this is how bad it is. they just arent moving and object arent even moving themselfves, even the shark isnt. whats the issue ?

Hey! I cant pickup the items from the reft :-(

I tried to find the output_log.txt in the folder you mentioned... Can you please help?

here's a bug, when i chop down a tree i cant pick up the coconuts

I have found a couple of bugs that I'de like to report, At start it works perfectly, But after we see 2 sharks, Each of them bites 15 seconds after the first one, I can attack only my shark and he can attack his,
If my shark destroys a piece of the floor My friend wont see it destroyed,
Now, We have a problem with throwing things, After a while when we throw items to one another It wont show up to my friend only to me, and In cases it does show up I can take the item he threw and then he can take it as well, Now the main problems


My friend cannot see chests that Im placing down,
and If I'm cooking something, Food // Water/ It wont show up to him cooking, Which glitches the game more then a bit,

I cannot see my friend holding anything part then the basic tool (the hook)

and we see ourselves as a wooden pupet, Try giving the ability of customing your player, hair beard etc

(+1)

Every time we save the world and shortly afterwards how to get on the server we have to start from the beginning we please help us

I wasn't able to fish with this I don't know why.

Where is the FAQ?

https://drive.google.com/drive/folders/0B-1nBrFu7dfuWDFPYjZKN3ppQlU

I got both versions and in V1.04 we can see each other but in version V1.05 we can't see the model.

In both versions we are having some issues that prevent the gathering of resources for the 3 connected to the server.

Can you help or point what's wrong?

Developer

Unfortunately, but I'm no longer supporting the modification because the developers of raft will add a multiplayer in to game themselves in 2018. So you have to wait until it game comes out on steam.

no player model dont know why

Hi,

I'm having an issue and as are my friends that we can only see eachother's shadows? The player model doesnt render whatsoever and its annoying xD. We can periodically see names but very rarely. Know of a fix?

Laszl0