Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Asset Forge

Create your own 3D models and 2D sprites! · By Kenney

Importing Collections on Mac OS not working

A topic by ilanvandijk created Feb 11, 2019 Views: 137 Replies: 6
Viewing posts 1 to 5
(1 edit) (+1)

Hi all,

I've been using AssetForge on Windows for sometime now without any major problems.
Now i'm at the office where we all have Mac OS running and trying to get AssetForge to work.
The install went flawless, although i can't access any custom blocks out my 'Collections' folders - which is the one this extremely useful for me.

I've followed these steps just to be sure: https://itch.io/t/120813/launching-on-mac-os
But still only default models will load, no customs - any advice?
Thanks in advance!

EDIT:

I found the solution, just posting this in case someone has the same problem - i've installed AssetForge directly from the download link on my Mac, for some reason then loading custom blocks won't work - perhaps looking in the wrong location for the Collections? This is fixable by uninstalling the directly installed AssetForge, download and install the Itch app and then go there to your library to install / open AssetForge. It now will have another location on your Mac and loading models out of the Collections folders should work fine now.

I can't get to use or make Assetforge see custom blocks on Linux either... Wonder if anyone else has this problem. I'll try it on my Mac tomorrow, so if that at least works, I can get by on that for the time being....

Did you try installing it with Itch App instead of standalone Assetforge? Try to uninstall Assetforge, Install the Itch application, and look for Assetforge in the Itch application. This way it worked for me.

(+1)

Thanks for the replay ilanvandijk. It worked fine on both Windows 7 and Mac OS X, but still not in Linux, both outside the Itch app and inside. The app is a bit flakey as it is anyway, so I'll just use it (and save often) in Windows/Mac for the time being until version 2 is released.

(+1)

Sorry you're encountering this issue, it does indeed seem (like you've mentioned) that it somehow looks in the wrong folder. I'm not too familiar with Mac OS and Linux as a whole so any issues there take a lot of time for me to figure out and fix - hah! For the 2.0 I'll make sure to get some Mac OS and Linux testing folks on the team to make sure that everything works flawlessly.

Hi Kenney,

I'm an developer working both on Windows and MacOS - when you're ready for testing the new version i'd like to offer myself as a tester (for Mac) if you haven't found a reliable testing team yet.

I understand it might still take some time before we're that far but maybe to keep in mind if you have issues finding Mac users. Have a great one!

Wow, that was hard!  The AssetForge app doesn't reside in the generic applications folder, but rather my personal applications folder under the itch app (thank you for that tip, btw):  Macintosh HD/Users/User(me)/Library/Application Support/itch/apps/assetforge-deluxe/collection.  I haven't managed to put assets in there yet but at least the new folder I created appears inside Asset Forge, so it's a start.  It should also be noted that the Library folder is hidden by default in MacOS.