Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Bought latest (Oct 2018) version, ran fine on Windows 7, now crashes

A topic by CatsAreGods created Dec 26, 2018 Views: 147 Replies: 5
Viewing posts 1 to 2

Tried it a few times, then updated display driver...still nothing. Not sure if you want me to paste the whole error log here and not sure how to attach the crash.dmp but here's the beginning of the log:

Unity Player [version: Unity 5.4.1f1_649f48bbbf0f]

FPVFreerider.exe caused an Access Violation (0xc0000005)
  in module FPVFreerider.exe at 0023:b642cf30.

Error occurred at 2018-12-26_125444.
G:\Large Install Files\FPVFreerider.exe, run by david.
57% memory in use.
0 MB physical memory [0 MB free].
0 MB paging file [0 MB free].
0 MB user address space [3662 MB free].
Write to location b642cf30 caused an access violation.

Context:
EDI:    0x00000003  ESI: 0x038a4c90  EAX:   0x016d17a8
EBX:    0x03877dc0  ECX: 0x038a4c90  EDX:   0x00974c20
EIP:    0xb642cf30  EBP: 0x0023facc  SegCs: 0x00000023
EFlags: 0x00210202  ESP: 0x0023fab4  SegSs: 0x0000002b

Bytes at CS:EIP:
?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ??

Developer

Did it run fine several times, and then suddenly started crashing?

Are you still running it on Windows 7?

Maybe there is some problem with the memory.  You could try running it in a window (as described in the manual) and see if that makes a difference.

I've used it for weeks, and it only started crashing recently. Tried in a window, no go. Always been on Windows 7. I have 16GB of RAM and plenty of free resources...puzzling!

Developer

Yes, that is puzzling. One thing is for sure - FPV Freerider cannot change by itself or auto-update somehow. Since it worked before I guess it must be that there is something that has changed in your system, perhaps some driver update or something.

To make sure that there is not some missing or corrupted file you could first try to download the entire Freerider zip file from Itch again and unpack it.

Thanks for the idea. I actually just re-unpacked and reinitialized everything, figuring that it might adjust to whatever changes Microsoft applied to my system...and it worked!

Developer

Great, glad to hear you got it working!