Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Android

A topic by bright_visions created 11 days ago Views: 55 Replies: 4
Viewing posts 1 to 2

Will the game require Android 8.0 or is it possible to play with an slightly older device?

Game looks pretty interesting, it would be a shame if I couldn't play it because my phone is too old

Developer

Does the demo run on your phone? There are some Android phone/versions that are incompatible with our engine, but the incompatible combinations can include 8.0+.

I downloaded the Play Store App and it crashes instantly after starting. My phone (honor 6x) has the Android version 7.0 

Developer

Can you let us know if the newly updated Android build ([DEMO][Android][Renpy 6.99] Red Embrace: Hollywood) here does or doesn't work?

Yes, the demo works just fine if downloaded from itch.io