Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Return of the Tentacle

Sequel to the Point&Click-Adventure "Day of the Tentacle" · By catmic

Cool game! But I got a problem

A topic by podex created Aug 06, 2018 Views: 668 Replies: 7
Viewing posts 1 to 5

I was a fan of the first day, the tentacle was on earth, and from the graphics I've seen, I think I'll also like the return of the slimy "monster".

But when I tried and started the 64 Bit version, I got the error


Desktop is 1440 x 900 @ 60 Hz
Unable to find a supported OpenGL core profile
Failed to create valid graphics context: please ensure you meet the minimum requirements
E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
[Vulkan init] extensions: count=2
[Vulkan init] extensions: name=VK_EXT_debug_report, enabled=0
[Vulkan init] extensions: name=VK_EXT_debug_utils, enabled=0
Vulkan error VK_ERROR_INCOMPATIBLE_DRIVER (-9) file: /home/builduser/buildslave/unity/build/Runtime/GfxDevice/vulkan/VKContext.cpp, line: 305
Vulkan detection: 0
No supported renderers found, exiting
(Filename:  Line: 560)

My laptop has no special video card, it's a plain Intel and I am running the latest Mint 19


lspci|grep -i display
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

cat /etc/lsb-release

I do not have a AMD Vulkan or so. Is this game just running with Vulkans?



Unfortunately, our game does not support OpenGL GPUs prior to v3.2. You'll need to get a GPU that is at least OpenGL 3.2 compatiable.

Thanks for your answer!

Of course, the laptop is not the only machine in my vehicle fleet. Does it work on Raspberry 3, I am pretty sure it will work on my  stationary PC, there I think I have a Radeon GPU (this I can replace in case I need a newer one)



Our game cannot run on ARM/Linux. Try the game on your PC, this is your best shot. :)

Hi again,

Well, Raspberry Pi 3 is not working, OpenGL 3.2 is missing.

So I checked it with my desktop PC, there the GPU is ok, I have OpenGL 3.3, but I get an "unhandled NULL exception":


Desktop is 1680 x 1050 @ 60 Hz
New context 0x2fcec10 created with attributes:
Initialize engine version: 2017.4.7f1 (de9eb5ca33c5)
GfxDevice: creating device client; threaded=1
Renderer: Gallium 0.4 on NVCE
Vendor:   nouveau
Version:  3.3 (Core Profile) Mesa 10.1.3
GLES:     0
 GL_ARB_ES2_compatibility GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_clear_buffer_object GL_ARB_color_buffer_float GL_ARB_copy_buffer GL_ARB_conservative_depth GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_get_program_binary GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_robustness GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_bit_encoding GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_packing GL_ARB_shading_language_420pack GL_ARB_sync GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map_array GL_ARB_texture_float GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rgb10_a2ui GL_ARB_texture_rg GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_binding GL_ARB_vertex_shader GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_abgr GL_EXT_blend_equation_separate GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_provoking_vertex GL_EXT_texture_array GL_EXT_texture_compression_dxt
1 GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_mirror_clamp GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_OES_EGL_image GL_OES_read_format GL_KHR_debug GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_shader_trinary_minmax GL_ATI_blend_equation_separate GL_ATI_texture_compression_3dc GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_multimode_draw_arrays GL_MESA_pack_invert GL_MESA_texture_signed_rgba GL_NV_conditional_render GL_NV_depth_clamp GL_NV_packed_depth_stencil GL_NV_texture_barrier GL_NV_vdpau_interop GL_S3_s3tc
OPENGL LOG: Creating OpenGL 3.3 graphics device ; Context level  <OpenGL 3.3> ; Context handle 50129936
AudioManager: Using PulseAudio: Default Output Device
Begin MonoManager ReloadAssembly
- Completed reload, in  0.021 seconds
WARNING: Shader Unsupported: 'Hidden/BlitToDepth' - Pass '' has no vertex shader
WARNING: Shader Unsupported: 'Hidden/BlitToDepth' - Setting to default shader.
WARNING: Shader Unsupported: 'Hidden/BlitToDepth_MSAA' - Pass '' has no vertex shader
WARNING: Shader Unsupported: 'Hidden/BlitToDepth_MSAA' - Setting to default shader.
New context 0x36d1800 created with attributes:
Default vsync count 0
requesting resize -1 x -1
Using native desktop resolution 1680 x 1050
requesting fullscreen 1680 x 1050 at 0 Hz
Desktop is 1680 x 1050 @ 60 Hz
Receiving unhandled NULL exception
#0  0x007fbd22b96d00 in _L_unlock_13
#1  0x007fbd22b97290 in nouveau_pushbuf_data
#2  0x007fbd22b972f0 in nouveau_pushbuf_space
#3  0x007fbd22b97340 in nouveau_drm_screen_create
#4  0x007fbd22b97380 in nouveau_drm_screen_create

For my NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1) I am using xserver-org-video-nouveau, is this driver not recommended? I am using

Linux Mint 17.2, there is a driver suite called nvidia-384 available, is this the better one?


On NVIDIA GPUs, it is recommended to use the manufacturers proprietary driver for gaming. So yes, pick that NVIDIA driver!

Well, I switched to the preferred (according to Mint 17.2) nvidia-384, now it works!

Very nice game, I like it a lot!!!!!!! Thanks, I am looking forward to see the next adventure, no problem to spend some money...



Great you got it working! We are happy you enjoyed our game. :D

Please spread the word about our game :)