🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bug thread Sticky

A topic by Athanasius created 1 year ago Views: 1,221 Replies: 27
Viewing posts 1 to 15
Hey

I'm really enjoying Ara Fell so far. I've encountered my first nasty bug, so I thought I could open a thread to let you know. If I encounter others, I'll write them down here too.

Bug: On the map "Starway", at the place with the little pond and the water cave (right south of the pirate cave): It is possible to access that cave from land (from right behind the apple tree) - but if you do so, you'll not be able to swim and be stuck between the cave entry and the cave. As you can see, Lita doesn't swim if you access the cave from behind the apple tree and so gets stuck.

Developer

Thank you, we'll fix this ASAP keep a look out for a patch!

Hello, I just signed up here just to purchase and download this game. :) Unfortunately I'm encountering control problems and it's not the kind listed in the ReadMe.

Basically the game starts perfectly fine, but then I'm stuck in the main menu when I want to select to start a new game. The arrow keys don't work at all, the only key which actually does something is, for some reason, the 'alt' key which lets me select the different options, acting like an 'up' key, but there's no way to confirm anything. Besides the 'alt' key, only the keys for resizing the window work (and they do as intended, meaning no strange key remapping there), as is F12. But none of the keys listed in the manual do anything and when I pressed every other letter and number to see if some odd remapping was going on, I found no other key doing anything, either. The game otherwise seems to run normally, music and everything is there.

Thing I checked:

- Followed the troubleshooting problems in the ReadMe despite my problem being a bit different. I restarted my computer = no change. I unplugged every USB device and restarted again (I have no controller of any kind, but a mouse since I'm using a laptop) = no change. I then also disabled my WLAN and restarted again. Again, no luck.

- I changed my language setting of the keyboard back to German (I'm from Germany and had changed it to English because of the y/z switch of the keyboard). Nothing.

- I tested all my other RPG maker games to see if they have the same issues, which would clearly indicate a hardware problem on my end. But they all work fine. I'm not sure with which RPG maker version they were made, though; I think this is the first RPG Maker 2003 game I own.

Things which might be important: My laptop uses Windows 7 Home Premium 32-bit, my graphic card (is it called that in English? I'm sorry, since I'm not a native speaker I really struggle sometimes) is called ATI Mobility Radeon HD 565v. The game is unzipped into a folder on my desktop, but moving it to a different location didn't help. I also tried deleting and unzipping it again, but that also didn't change a thing.

I also noticed that, compared to the Let's Play I watched, the screens in the beginning of the game (the two logos which appear before the main menu appears) disappear for me at a much faster rate, I see each only for a split second.

Any help would be really appreciated! I decided to buy this game after seeing the beginning of a Let's Play on Youtube and it looked so amazing that I decided to buy and experience it myself instead of just watching a Let's Play. So I really hope this problem can be resolved!

Developer

Hello!

This does seem to be what the problem that the "stuck key" glitch causes where buttons such as alt still work but the arrow keys refuse to work. It's extremely frustrating and sadly something we can't fix but normally just restarting your PC will allow you get back to playing.

I made a really simple test for you to check the game which you can download here! If you're not getting the same results, if it's working check to see if it's fixed in Ara Fell and if not please inform me and I'll look into what's messing with your computer!

We are currently working with EasyRPG to help develop their RPG_RT interpreter so hopefully if this continues to not work for you in the future you'll be able to play with the new runtime application.

We apologize!!!

Heya!

Thank you so much for trying to help me! I downloaded the file you sent me, unzipped it and started it, but it just tells me "RPG Maker 2003 not found" in an error message and shuts down.

However, I tried some other things: After confirming that my other RPG maker games were not made with RPG Maker 2003 but other versions, I downloaded a free RPG Maker 2003 game and that game indeed suffers from the same/similiar problems as Ara Fell (besides the Alt key, in that game the z key works as if it's the menu key, but that's all - no arrow keys or anything). Meaning it's a problem on my end and I started checking what it could be.

What I found: When I restart my computer with my mouse and my Internet device (some mobile internet webstick) unplugged and then start the game, it works! :D But as soon as I plug any of the two devices back in, it stops working immediately. Even if I have it open. Having Ara Fell open and plugging the USB-device(s) in also causes my laptop to go into CPU-eating frenzy for a few seconds while normally it doesn't care at all when I plug my mouse or webstick in. When I unplug the USB-device(s) again, the game still remains unresponsive. Meaning that I can play the game - which I am extremely happy about - but I cannot use my internet or my mouse or I will have to reboot to play again. Which is very inconvenient since I'm 100% a person who likes walkthroughs to get every single thing in video games and I also am bad with a touchpad, so both internet and a mouse would be helpful.

Right now I'm happy that the game works and I hope it will continue to do so and that I won't run into the "sticky key" issue on top of the hassle I already have. Thank you very much that you guys look into fixing these issues for good! I would love to not have to reboot my computer every time I want to play. ;) But right now I can work with this and I have a lot of fun exploring Aloria at the moment. :D

Now that the game works for me, I stumbled upon a big bug (unless it's intended): In the castle's library, the refund for already-bought skills seems to be wonky. Lita's Multishot I costs 15 coins. If I already have it and buy it again, I get a refund of 250 coins. This is stackable, so I can puchase two at once for 500 coins and so on. It's very easy unlimited money, but kind of game-breaking.

Developer

Thank you!

(Edited 1 time)

More bugs:

- I seem to be unable to do anything with the "Vermin" quest in the Hunting Grounds where I am supposed to kill ten groups of enemies. The normal enemies running around aren't the needed type of enemy anymore; they upgraded when I got a full party. Once a group of weak, needed enemies jumped at me out of a bush in a small cutscene and I thought I was supposed to find ten of these encounters now, but when I checked in the item menu again, the quest still said I had killed 0 groups and I couldn't find another encounter like that one, either. Is the quest undoable?

- Very, very often when I want to turn Lita into a spirit at the grass circles, the game crashes with an error message (something about exceeding something at -1). I've lost a ton of progress because of that before, which is sad.

EDIT: The complete error message is "List index has exeeded its valid range (-1)".

- I keep seeing a sprite of a small girl with green hair who seems to be a placeholder or something? The first time I saw her in the Blood Forest Ruins in the screen where you get the melody for your flute. She appeared in the doorway at the very far right after I've gone through the door and then immediately back out. She stood in the doorway and didn't move and I couldn't talk to her. She stayed even after walking in and out of the door (therefore changing screens) a few times. The second time I saw her when I uncursed the statue in the Grand Bazaar. The soldier walked towards the exit, I tried to catch him to talk to him again and above the entrance he suddenly turned into the green-haired girl. Again I couldn't talk to her and just walk through her.

- No clue what was up with that, but the game softlocked on me after defeating Nash and returning to un-cursed Aloria. After visiting her father and walking downstairs, Lita called everyone to talk to them and after that first dialogue box I got nothing more. The new music started and all, but I just didn't get the next textbox. Redoing the whole thing went fine, though.

Aaaand... it appears I encountered a game-breaking bug and am stuck for good. Unless I'm dumb. But I don't think I am. Because I can't figure out where things went wrong, I'll describe what I did.

I'm in the last dungeon and had/have to find two gold keys. Because I couldn't figure out the lever puzzle in the left building, I went to the right one first and got a normal key. Didn't see the door because I'm blind, so I took the normal key to the normal lock in the left building and fought the three dragons. The game told me I got a gold key from them, I teleported out and went back to the lever puzzle. I figured it out and freed two elves but couldn't find the third one, so I took a break, saved and closed the game.

I tried again a few hours later and then found the last of the elves being invisible by the pond in the entrance area (another bug?) by helplessly running around and trying to examine things and so got the next normal key, which I took to the building on the right. Unlocked the door, fought Horror, used the grass circle, got the chest with the second golden key.

Except when I went to the door with the golden lock, the game still told me I need two keys. Checking my inventory, it says I only have one. =/ My guess is that I maybe never had the one from the dragons or "lost" it because while looking around for elves I went back to the dragon fighting spot, went to the screen south of it and when I wanted to go up again the game asked me again if I want to save and then proceed even though the dragons were dead. The fight didn't trigger again or anything, there's the teleport spot there and that's that. But yeah, I should have two golden keys but only have one and am therefore 100% stuck and unable to proceed. Reloading didn't help.

Any help? What do I do now?

Developer

Hey there Sheba! I'll respond to these issues in the order you posted them. And sorry for all these issues. It's a lot harder to update new versions on itchio. On steam, we can fix any little thing immediately, but we have to upload a whole new copy of the game for itch.

re: hunting range

This is another weird bug where the counter isn't updating correctly for reasons I don't understand. I tried a bunch of random things and I think I've identified the problem. We'll upload a new version of the game tonight.

re: index -1 errors

Sorry about that. Those have got to be really frustrating... I'm not entirely sure of the cause, but you're the first to bring it up since we released. That happened several times during beta testing. I made some changes, couldn't reproduce it again and the testers stopped bringing it up.

It's a very strange error... I'll keep looking into it. At any rate, I do apologize for the trouble. Does it seem to happen randomly? If you can find a place where it happens consistently, would you mind uploading your save game for me and I'll have a look? Thanks!

re: small girl -

That was a silly mistake on my part. I used a blank graphic as a placeholder in some places, then added a graphic to it but forgot that I was using it as a placeholder. The version uploaded tonight should fix it.

re: Game-locking up.

This can sometimes occur when you skip through messages too quickly. Do you remember what the last thing that was said before it locked up by any chance?

re: Last dungeon

Was the elf at the beginning near the pond truly invisible, or did it just blend it with the rocks?

If you upload your save somewhere, I'll add a gold key to your inventory. Looking around, I don't see why you'd lose a key in this way... There was an issue before with items disappearing. Not sure when you last downloaded the game, but that should have been fixed a few days ago...

The engine we're using is very poorly optimized (not our fault, I promise!) so a lot of the code resolves itself slowly, especially on slower computers. I wonder if that might have something to do with what's happening here. At any rate, I will look into this gold key issue. Upload that save and I'll get you going again!

(Edited 2 times)

Thank you so much for responding to everything!

About index -1 errors:

What I noticed is that it's very likely that it happens if it's the first time I'm doing it during my game session and the last game session wasn't shut down because of the error. Which sounds weird, but that's really how it is. If the game shut down because of the error, I can be basically sure that it won't happen again when I start the game once more and use the same circle again right away then. Also if it works, I can be sure that every other grass circle on the same map will work fine as well until I switch screens. If during a gaming session I successfully used grass circles on any map before, the chance of the crash happening during the same session on any other map seems to be very low as well, but it happened before. But generally, the first grass circle during each game session when the game session before has been ended normally and not with a crash by this error is the "dangerous one".

About the game lockup:

I remember Lita saying something along the lines of "Everyone, we need to talk", everyone else stepped closer to her but then Lita never talked. I believe it was the first thing she said when she came down the stairs after her father went to sleep.

About the last dungeon:

The elf was invisible. Absolutely, totally invisible. I know that for sure because I checked literally everything in that room when I discovered that I could get a "all you can see behind the gate is a pile of rubble" (or something like that) message when I checked the cracked gate and I was desperately looking for clues where the elf could be. I wanted to see if I could check out the other gates and blocked places in the room and for the first time went above the pond and literally bumped into the elf who appeared right that second.

I tried uploading my save file, I hope this works, I never needed to upload anything like that before so I had to google a random website to host stuff like that: Link

I think (not sure) I saved on the screen south of the dragon encounter (which is finished and over); that way you can also see how the message about the Point of No Return keeps popping up there for no reason when I try to switch screens.

Also, since you just said something about items disappearing: That happened to me today before, I had totally forgotten to report that as well over my shock of losing my gold key. It must have happened somewhere in the Holy Land, I believe; I found a Magic Elixir in a chest and when I wanted to use an item in battle I suddenly only had that Elixir and all other healing items were gone! I normally really rarely use items, though, so I might have lost them much earlier and only noticed then. At first I didn't even think much about it since I thought it was actually a plot thing (like the fairy teleporting me but leaving my items behind) and only later noticed they were all gone for good. But yeah, I had been swimming in money so much that I didn't even really care.

(EDIT: Unless you lose all stuff except for the healing items when you enter the last dungeon, the item loss actually affected my whole stuff, not just the healing items and/or gold key. I just checked. I usually sell my unneeded equipment, but there had been things I've kept - like the Ring from the Well+3 since I still hadn't decided if I should give it to the NPC or not. My inventory is VERY empty - I check that thing so rarely - I don't even have my crafting stuff anymore except for an Essence I probably got from a boss encounter. Maybe I lost much more than just my gold key, uggh. I suppose it's okay, but still. Maybe that's also the reason for the small bug I mentioned below, about the quest person in hunting range giving me her quest again. Maybe I literally lose the quest since it's stored in my inventory.)

Thank you so much for helping me out so quickly! As for when I downloaded my version, that was Monday the 6th on 3:30am German time (it's 5am on the 9th right now here.).

More Bugs:

Also another, super-small bug: Once I've done the quest for the old man wanting to see the elven shrine in the Holy Land and he gave me my reward, he just stands there and doesn't talk to me anymore. Also he was totally gone during the vampire assault and afterwards until I returned from the Holy Land and I had already been scared he wouldn't come back.

Oh, and the person with the bugged hunting quest keeps giving me the quest anew ever so often for a reason. Not that it matters anymore since all my quests have disappeared when I entered the last dungeon (probably intended, even though I can backtrack).

Aaaand another small bug which was weird: After the big cutscene at the beginning of the final dungeon (trying not to write too many spoilers here for people who read this...) when all the NPC allies first come and then retreat, I can go out of the front door of the dungeon for the first time and use the crystal to warp around. But all places are suddenly "stuck", as in the screen doesn't scroll anymore, so I can't move around much. I can still go into doors and all when they are on screen (like in the Bazaar, the upper door to the armory). Things worked again when I progressed a very tiny bit and saw another small cutscene (about Lita sending a certain dwarf back because she wants to handle things alone) and the dungeon began for real. Then the screen scrolling worked everywhere again.

EDIT: More bugs I remembered! There were several sprite errors during the Orlian time. The first time it happened after I had been told in the temple to stay at the Inn for free. When I talked to the Innkeeper, Doren started to talk to her and for some reason, the Innkeeper walked left a step and then faced an empty space while talking. I suspect Doren was supposed to appear when he started talking, but never did. This continued during the next scene when Doren and Seri talked while Lita and Adrian played cards. Durng the whole scene, Seri's sprite was missing. Which was really sad, since it's obviously an important scene. I actually reloaded and watched the scene again because I wanted to see if that fixed matters, but it didn't.

Also after the vampire attack on the temple, when I am supposed to go to the Holy Land and some normal temple NPCs have returned, but the dead NPCs are still around, the nun in the temple basement who was yelling at the man sleeping on the floor is still there, yelling... except that the man sleeping is gone, so she's yelling at no one, lol. After the Holy Land, once the dead bodies disappeared from the temple, the sleeping man was back.

Developer

https://www.dropbox.com/s/wunwgbd35grdx6a/Save01.l...

Here's your save! And you're welcome! I'm just sorry you ran into these issues. Some of them aren't really our fault, but some of them are... so I really do apologize for that!

I added a gold key to your inventory. Incidentally, dropbox is the file-sharing upload site I'd recommend using generally. Filedrip worked fine, but dropbox is really useful and it's worth taking the time to make an account if you ever need it!

For the flying error... man. That really is weird. I'll just have to randomly play around with stuff and see if I can improve it. I can't recreate it myself though, so it's really difficult to test...

As for the game locking up, the latest version should fix that.

For the last dungeon, I've checked and rechecked everything that would make the elf statue disappear and I can't find anything. I'm going to hope it's just a freak thing since this hasn't been brought up before, but if you notice it in another playthrough or anything, please let me know!

Thanks so much! I gotta ask though: Was it really needed that my characters all got set back to level 1 and got their starting equipment put back on? Lita now is equipped with "Artifact of Power+1" and has "Artifact of Power+6" in the inventory and I have no way of switching it back since it's bound. Also of course at level 1 everything in the last dungeon one-shots me. If I really need to level up to around 30 again I guess I'll have to do it, but yeah, not my favourite activity.

Dropbox sadly doesn't work well for me, I'm currently stuck on 64kbit/sec internet and have no access to DSL in the region where I live, so Dropbox - which I once used - is not very ideal for me right now.

Stuff I can say for the flying error even though it's probably unrelated: I play in windowed mode. When the previous game session has been closed via the x in the corner (so not with a crash), I can be 90% sure the first grass circle in the next gaming session WILL crash my game.

Hm, running a story mode run and skipping all cutscenes SHOULD make another run to the last dungeon doable in an okay amount of time, but given how much I played in the last three days (showing by how I basically am at the end of the game), I don't really feel like doing it just for the elf. :P Though I do have to admit I'm intrigued if it would happen to me again, haha.

Developer

... Oops. No, it wasn't necessary! I have some beta tester code, but I didn't realize it would reset your level. I'll fix this a different way and re-upload it for you. Just a sec!

https://www.dropbox.com/s/wunwgbd35grdx6a/Save01.l...

There you go. that should do the trick.

Awesome, thank you so much! :D Now I can finish my game! And who knows, I might just do a speedrun to see how quickly it's doable to investigate that "invisible" elf. While waiting for your reply I checked how quickly stuff could be done and I got to looking for LIta's dad in the hunting range (where I'm now stumbling around again since like ten minutes, finding these three spots where the cutscenes occur is like the hardest quest in the game. xD)

Really, it's awesome how helpful you are and how quickly you fix bugs! Thanks so much for the awesome customer service!

Developer

You're very welcome! I'm glad you were able to enjoy the game despite the bugs!

(Edited 5 times)

Two minor "bugs?" I've discovered while playing so far.

When everyone get's turned to stone, this guard does not, http://i.imgur.com/O604EPa.png

These two didn't either http://i.imgur.com/dJR14EF.png

And this fellow turns to look at you when you try to talk to him even though he's turned to stone.

Before http://i.imgur.com/haFO86d.png

After http://i.imgur.com/5A6KK6e.png

(Also, shouldn't the bridge trolls also be turned to stone during this time?)


This one's somewhat nasty.

Start here at the springs http://i.imgur.com/hkoI0XK.png

Swim down from either of the water spots except for the one you came from http://i.imgur.com/vmnyyyE.png

You end up here http://i.imgur.com/0t3RlNg.png

Swim back up http://i.imgur.com/VWlG5Bh.png

And now you're permanently stuck. Reload last save. :(


I don't ever recall opening this chest seeing as I needed flight before I could open it, but when I flew over it was already empty. http://i.imgur.com/2EUSxz5.png


"Bug?" Fog persists in within these two zones after the vampires have cleared out. No fog left otherwise except when using the teleport. The main area then is then temporarily covered in fog once again until you exit the zone and come back in. http://i.imgur.com/Mt0PV7o.png http://i.imgur.com/CMzqNT8.png

Developer

Thanks for bringing these up! We'll get them fixed right away and get a new version posted soon. Sorry for the trouble!

No worries. I picked Ara Fell up on Steam and have a good bit of free time so I plan on doing a thorough playthrough. I'll be posting bugs once in a while as I find them.

(Edited 1 time) (+1)

So, I just donwloaded the game, and it doesn't start.

I run the RPG_RT-file, but nothing happens after that.

The demo runs fine though.

EDIT:

I copied the RPG_RT-file from the demo to the full game, and now the game runs fine, and there is no "DEMO" shown on the start screen.

Seems to be a bug in the RPG_RT-file.

Developer

Thanks for the head's up! I must have mixed up versions of RPG_RT at some point.

No problem.

Downloaded the new version, and it works fine now.

(Edited 1 time)

"Bug? Bunny girl bandit disappears from her cave when everyone turns to stone."


After "defeating" Lord Nash, and the stone curse is undone, Lita is to go back to Aloria and see how things are. You can choose to ignore this and go around to other places. Here are a few bugs that I've run in to while looking around.

blood forest guards

You can speak only one of outdoor guards. He says "If you have a pass…" which you don't have yet after Lita replies "Yeah, me neither" he lets you go by and does nothing. The other guards just stand there and aren't intractable nor do they turn around to look at you when you move past them like the guard in the picture, as if they're still made of stone.

http://i.imgur.com/EOYQ0M4.png


graveyard battle blood forest

Sometimes you get the graveyard battle scene in the blood forest, it should be the forest battle scene. Infrequent, only happened 3 or so times in the numerous battles I did there.

http://i.imgur.com/9kexAUU.png


returning/return to Aloria

You can walk all the way around to the other side of the "wall" that prompts you to return to Aloria and not pass through. Can be done on all the paths in the blood forest leading up from the orchards. The same thing happens when trying to go up/down on this bridge. You face Aloria yet Lita says it's the other way.

http://i.imgur.com/lAGwpw2.png http://i.imgur.com/vIpHzNT.png

http://i.imgur.com/0WpKEYZ.png http://i.imgur.com/SumWHCu.png


Adrian stone free cut scene

Cut scene does not happen when approaching Adrian from below. He magically appears in the party if you enter Aloria at this point when you don't interact with him, yet a figure of him remains on the bridge. He's in your party and yet there's a permanent figure/doppelganger of him on the bridge which can't be interacted with.

http://i.imgur.com/0jOazyk.png


walk through walls

If you crouch and walk back in forth under traps (these were a some spike traps) a couple of times you can now walk through walls. Fixed after crouching and uncrouching in a normal area or fighting an enemy. If you open a closed door you can walk through it to that area. Potentially save breaking if you get stuck in a zone with no way out after the state of the character gets fixed. I bypassed multiple scenes like this.

http://i.imgur.com/9ohoVeI.png

(Edited 1 time) (+1)

Hey,

I've downloaded the recent version of Ara Fell and tried to start it. It gives me the error message

"The required file 'ultimate_rt_eb.dll" could not be found! You might need to reinstall this game"

The earlier version worked without such errors.

I've downloaded the game several times now, but it's still the same.

Can you please help me?


EDIT: the file is definitiely missing in the main download. The demo version has it.

(Edited 1 time) (+1)

I'm getting the same problem. Can we manually replace the file somehow? Download the demo to get it?


EDIT: Tried copying the file (and the "old" version) from the demo into the full game directory. This seems to have fixed the problem.

(Edited 1 time) (+1)

Hi Waltorious,

Yes, I did the same, but I'm unsure if it's the proper file or if there are limitations because if's from the demo-version. Could anybody from the team give a clear answer here, please? I hope you'll fix this in the download.

(+1)

I doubt there are any differences in the file between the demo version and the full game. .dll files don't usually have different versions. But it would be good to hear from someone on the dev team; at the very least, the missing file should be fixed in the download for the full game.

(Edited 3 times)

EDIT: This is solved; it was due to my soundfont settings (see below). Not a bug!


I'm having occasional problems with music and ambient sound triggering. Sometimes I'll only hear ambient sounds, sometimes I won't hear either. The main menu music always works though, and sound effects are fine. For example, I just finished the first major quest in Aloria, and after the ending cutscene and dialogs, there was only ambient sound playing. I tried saving, quitting to the menu, and restoring the save, and this caused even the ambient sound to cut out, so the game was silent except for sound effects. Restarting the game didn't' help, I had to reboot my machine and start over to get the music and ambient sound back. Possibly related: the first time I launch the game after booting my machine it hangs, and I have to kill it in task manager. After that it starts normally every time I launch it.


The sound issues may be related to the fact that I'm using a soundfont via VirtualMIDISynth to improve the music. I already had this installed so I figured I'd go for it, and it sounds fantastic when it's working, so I'd rather not disable it.

The sound issues are not game-breaking since I can restore sound with some fiddling and reboots. But if there's a better solution I'd love to hear it!


Also, I'm enjoying the game a lot so far!



EDIT: OK, the hanging on first launch thing isn't actually true, it just takes a really long time to load for some reason. I had music this time no problem, but it cut out again when leaving Aloria to the north for the first time. Saving and re-loading the save brought it back without needing to exit the game. Not sure why / when the triggers work or not.


EDIT 2: Behavior seems more consistent now. I'll have music, and it will change to a new track when entering certain places, but when leaving those places and entering the outdoors again there will be no music. Exiting to the main menu and re-loading a save fixes it. Not sure if this behavior is caused by using VirtualMIDISynth with a soundfont or not. But, it's not too hard to fix, so I'll keep playing for now.


EDIT 3: SOLVED! Turns out all the audio problems (and the long load times) were due to a setting in VirtualMIDISynth. It was set to load the entire soundfont into memory before running the game, but my soundfont is large (~2 GB) so this caused issues with audio playback. I turned that setting off and now all the music plays properly and it still sounds fantastic!