🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Game graphics squeezed on Macbook Pro Retina

A topic by danboarder created May 03, 2018 Views: 98 Replies: 6
Viewing posts 1 to 3

I have a problem on my macbook pro retina where everything is squeezed, unplayable --- see this screenshot (attached). It hasn't worked for a while. I purchased the Recharged version thinking this might fix it but both versions have this problem. Launched from Itch, latest versions.

Developer

You said it hasn't worked for a while - did it work at some point?

You can try to set the resolution manually and see if that helps.

It was discussed last day in this forum. On Windows you add command line parameters to the exe to set the resolution, for example:

-screen-fullscreen 1 -screen-width 1920 -screen-height 1080

Not sure how to do it on a Mac but I think you can use command line parameters on Mac and Linux too but I'm not sure exactly how to do that since I'm not using those operating systems myself, but here one way is described: https://superuser.com/questions/466917/how-to-set-launch-options-for-programs-on...

(1 edit)

Hi, I tried creating an alias from the command line as in the example, for example:

> alias FPVFree="./FPVFreerider_Recharged.app -screen-fullscreen 1 -screen-width 1920 -screen-height 1080" 

However I get this error when running "open FPVFree":

permission denied: ./FPVFreerider_Recharged.app

I tried with sudo and get 'command not found'.  So I'm not sure if I can start the app using parameters like this.

OK I figured it out.  I think this should be the default for your app but in the meantime using the following syntax will work. For anyone having game display problems on a retina mac with High Sierra, you can try the following:

Change directory (cd) to the folder with the game in it. For me, my user home folder is "dan", you'll need to edit this for your use:

cd "/Users/dan/Library/Application Support/itch/apps/FPV Freerider Recharged"

Then open the game using the OSX open command and --args parameter, with the app arguments as follows:

open ./FPVFreerider_Recharged.app --args -screen-fullscreen 1 -screen-width 1920 -screen-height 1080

This launches the game properly for a normal experience, it's a workaround but it works!

(1 edit)

I created a simple AppleScript icon on the desktop to launch the game, modifying this can work for people. It opens a shell and launches the game UI. Open AppleScript Editor (in the Applications folder), and paste the following in (edit your home folder):

tell application "Terminal"
    activate
    do script "cd '/Users/dan/Library/Application Support/itch/apps/FPV Freerider Recharged' && open ./FPVFreerider_Recharged.app --args -screen-fullscreen 1 -screen-width 1920 -screen-height 1080"
end tell

Note that if you have a slower Macbook Pro (2014 or older) you might want to launch the game at 720p instead of 1080p, it's more responsive for me this way -- I have a mid-2012 retina running MacOS  High Sierra 10.13.4 and the below runs best so far:

tell application "Terminal"
    activate
    do script "cd '/Users/dan/Library/Application Support/itch/apps/FPV Freerider Recharged' && open ./FPVFreerider_Recharged.app --args -screen-fullscreen 1 -screen-width 1280 -screen-height 720"
end tell

Developer

Glad you found the solution, thanks for sharing the information, I'm sure that will be of use if someone else has the same problem.

Deleted post
Deleted post