Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Bug Reports Sticky

A topic by Wanderlust Games created May 21, 2022 Views: 822 Replies: 15
Viewing posts 1 to 6
Developer

Please post any bugs, errors etc that you come across in this thread. Make sure to include a detailed description, including your platform, and a screenshot.
Before posting please ensure that you are playing the most recent version of the game.

(2 edits)

Hello, I have just downloaded the latest version of the game (ver. 6.1) yesterday and tried to play it today (first time playing it). But I seem to have run into a bug in chapter four, during the meeting in the streets of Cursa (this is happening on Damon's 'route', I have yet to try playing other characters to see if it happens regardless). I play on a Windows 7, 32-bit desktop system, and the game seems to crash whenever it gets to a certain line of dialogue. I have attached a screenshot of it and tried to replay that section several times, but always get the same result of the game crashing. I would appreciate any advice or help in the matter, as I would like to get through all the chapters available before I post a review for this amazing story. Thank you.


Developer (1 edit)

I'm sorry to hear you're having trouble with the game crashing, and tbh this is the first time I've seen this happen, especially in an earlier episode. There are a couple of things you can try. First (if you haven't already) you can try deleting all the A6 files from your PC and downloading the game again. My first thought is that something may have gotten corrupted when it was being downloaded the first time. The other possibility is that the graphics driver on your PC may require an update in your device manager. I've seen quite a few strange errors pop up simply because of the graphics driver, so I would recommend giving that a go and seeing if that fixes the issue. Please let me know if either of these work for you :)

I'll try re-downloading first and redo Damon's route to see if it happens again at the same spot. Because it hadn't had any trouble up to there. If it does, I'll try another route to see if it happens again and will keep you updated if it worked or not. Thank you for the swift reply.

Update: So, I've tried the following:

1. I deleted all files of the game, including the persistent file, re-downloaded and tried the same route only to have it crash at the same line of dialogue.

2. When that didn't work, I updated my graphics driver with the latest version I could find for it, and reloaded the game save point I had created just before the line where it crashes, but it still crashes in the same spot. So re-downloading and updating the graphics driver still don't work. I get the same crash on the same line of dialogue.

Again, I have not yet tried any other routes, this is happening on Damon's route. I don't know if choosing a different group for that chapter would result in a similar crash or not. And it's weird that the game worked perfectly for three and a half chapters, only to crash at that specific dialogue line, when there are no vfx or anything at play either. 

Or - now that I've updated the graphics driver - should I try deleting all files of the game again (including the persistent file) and re-downloading a third time and seeing if it works now? I'm just wondering if maybe because it's the same persistent file that the game created before I updated the driver, if that could carry the error over, after the update? I didn't get any sort of error or corruption warning when I extracted the game from the archive, so I'm not sure that's what causes the crash, unless there's some file in there that is corrupted and WinRar just isn't warning me about it before extracting.

So I'm kind of stumped on what to do. Is there any way I could send you the log file with the crash data so you can take a look at it? I couldn't begin to understand what it says, even though I looked through it. Could there be some error in the Ren'py script that causes this crash, maybe one that wasn't there before the last update of the game? To be fair I haven't tried the game before this latest update, therefore I have no basis for comparison, so I'm just throwing out potential theories.

Developer (1 edit)

If you can email the log file through I can definitely take a further look into this error. Our email address is hello@wanderlust-games.com. Thank you!

HI, I downloaded ver6.1pc and found that in chapter 6 after Ryona comes to MC's room, the scene when MC chooses to kiss her or not kiss, there's no bgm.

So I loaded the other characters' saves at the same scene, they all have a soft melody there, it only happens when the RO is Ryona. I'm not sure it's just my problem or other people have the same situation.

Developer

We'll check this out and make sure it works correctly in the next update, thank you for letting us know!

Just wondering if Damon should be that tall, this is during his route in chapter 6 just before Tilaarin.

Developer

We'll get that fixed for the next update, thank you!

No problem

Hello! For some reason, whenever I open the game and the game's menu pops up, I'm unable to press 'Start game', 'Load game', or any of the other buttons. I am using a Macbook Air (Retina, 13-inch, 2020), so I don't know if this issue is caused by my computer or because of the game. This glitch started today (June 5th, 2022) when I updated the game. Before that, everything was running fine. I've tried closing itch.io (I have the app version) and my whole laptop, but I'm afraid of doing anything with the files, since I don't want to ruin my save files. 
I've attached a picture of the buttons bellow, in case it's unclear what I'm talking about. Sadly, I can't upload a picture of the entire menu since it'll be more than 3 MB. Thank you!

Nevermind! I fixed the issue by downloading the game via itchio.io's online website. For some reason everything works well with the downloaded version but when I open Andromeda Six via itch.i's app, it doesn't work correctly? Perhaps something to still keep an eye on, but I don't need help anymore! I can finally play the game again! Thanks anyway to anyone reading this, and please do tell me if I have to delete this post.

Developer

We're glad that you were able to get the game to work from the website version. If you're still having issues playing the game from the itch.io app, uninstall and reinstalling the game files from the app version should help fix the problem. It's possible that the app version may have gotten corrupted during the update. And no worries about deleting the post, it could also be helpful to anyone else experiencing the same problem.

(1 edit)

Not a bug, but a misuse of word. Given the context, what the traveler is saying is that they want to provide help to the crew. So the word should be "unhelpful" and not "helpless". 

"Helpless" means receiving no help. As in "no one is helping this helpless person."

"Unhelpful" means providing no help. As in "this unhelpful person is not helping anyone." And this is what the traveler meant.

Developer

Thank you for your post! We've run this past our beta team for confirmation and in the context of this scene "helpless" works correctly as we're using it here as "I wish I could do something for them by myself" which falls under "acting without help" so we'll keep it as is for the time being. Thanks again!