Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Mr. Friendly

Randomly Generated Acts Of Kindness · By JP LeBreton

Known issues with current build Sticky

A topic by JP LeBreton created Mar 27, 2018 Views: 1,943 Replies: 46
Viewing posts 1 to 23
Developer (15 edits)

Overall Project Status: Alpha (ie mostly feature complete, still some bugs and missing assets)

There's no public bug tracker, so please feel free to reply to this thread with issues you find, things that seem like objective bugs rather than stuff that would merit further discussion (which you should start a new thread for).

What works:

  • 8 quest types + quest system that randomly makes unique quests available on each level
  • world interaction: view name & description of thing you're looking at, talk to monsters
  • 7 tools: "grabber", texture sampler, fishing rod, guardian vision, warp gem, secret finder, sector tool
  • UI: quest screen, inventory + crafting screen, HUD, "detector gem", tallies on automap
  • works with all official IWAD (Ultimate Doom, Doom 2, Final Doom, Doom Complete) maps

What's missing:

  • Some menu and title art

What's broken:

Developer unlocked this topic
(1 edit)

(edit: i was using wadsmush) i just played doom 2 from map 01 and finishing map 19. i did find a few errors:
-map 31 got a fishing quest, but the only liquid is a water ceiling i cannot fish on because the fishing beaver is floor-only

-map 32 keens and tag 666

-map 16 photo quest destination in the hidden teleport area where the monsters wait until they can hear you

-map 18 missing textures

-map 19 missing textures

-map07 ticks and traps crash on launch:

(also, not really a bug per se, but on map 06 a texture was selected by the quest. but that texture was a super obscure placement as the bottom of 3 different doors essentially obscuring the majority of the texture. so unless you dragged it into an editor and searched for the sector the quest was looking for you would not know where it was)

(thursday march 29th build) the only "bug" i could find wasn't even a bug, just in map 24 (the chasm) i was asked to find a texture which was a mid texture. and i can't select mid textures.

(1 edit)

Sorry I didn't see that "objective" bug reports were supposed to be posted to this thread - I'm going to merge my thread into this one. I believe I saw this on version #74846:

I was trying to craft but then I was unable to pick up items from my inventory screen. Then i got a vm abort. I'm not sure if I can reproduce it but here are some recent saves (I was using DOOM2.WAD) and a screenshot:


No worries! Thanks for the report. I added a few checks to this part of the code and haven't been able to repro it, let me know if you see it again.

(1 edit)

Getting this same problem on build 54. Rather constantly, in fact. Never on the first level but often within 3-4 stages. The inventory screen just does not respond to any clicks at all, and if you click to much you end up getting the "crash" a bit after you leave. Hovering functionality works fine though (item names and the glow around crafting spots).

Here's a save. Doom.wad.


Thanks! I just pushed an update (build 58) that totally refactors the crafting and related inventory code, so it should be more robust now. I can't repro the issue as described in the new build.

It looks like it's mostly fixed; I'm not getting it the majority of the time. I did run into one time though. It no longer ends in an out of bounds array access, no matter how much i tried to poke it, and unlike before while it stuck in the save file it didn't stick around when I reloaded from the beginning of the stage.

Here's the link. doom.wad again.

this should work right?


I started writing some dialog entries with that tag before I wrote the code to parse it properly, should be fixed now.

april 12th build. i don't know if this is a bug, it's fun, but it's super janky. feels really off. as a side little "haha" it's fine. but it just feels like i am destroying something beautiful by doing this in actual play.
Developer (2 edits)

A couple days ago I changed the Texture Sampler to swap its texture with what's being sampled, so most of the behavior you're seeing in that video is intended... you can certainly butcher a level's texturing with it but I wanted to try it out and see how fun it felt.

The bug there is that you were somehow able to sample the temp "no tex" texture multiple times and stamp it everywhere; my idea with the swapping mechanic was that you could never destroy or duplicate any given texture in the level more times than it originally appeared.

(2 edits)

To reproduce, with version 44 complete MAP31 in DOOM2.WAD with the Wandering Demon page finder mode turned on

UD e1m4: fishing out a dopefish for the quest, dropping it, picking it back up during diving placeholder animation played. it said i could return to the quest sender and the game crashed to console when checking inventory


Should be fixed now. Issue was stashing a fish while it was diving back into the water.

Minor spelling error (brough -> brought)

This journal page spawned a tad too close to some walls. Looks a bit silly.

Quests can end up on the boss in E3M8 (and presumably E2M8), making them uncompletable because talking to them ends the stage. Currently it's happening on E3M8 in level-based randomness mode.

Ran into another fun little quirk: you can be asked to get a switch texture that you can't get anymore, because you pulled the one-time switch with the texture and now it's another texture. The detector gem still points to the pulled switch, but grabbing the texture doesn't solve the quest. Tripped me up on Sever The Wicked; was asked to get the "skull switch on wood" texture in the "unpressed" state, but the only switch of that type is the one right next to the starting point and I already turned into the "pressed" texture right off the bat.

Finished up and found two more things going wrong in MAP30:

First, at least in Doom 2's map 30, if you talk to the one and only enemy and try to get his quest too quickly, GZDoom freezes and needs to be end-task'd. I think the point at which your are safe is when the first cube lands and spawns a demon; merely waking the boss brain isn't enough.

Second, if you pick up and throw the Wacky Wizard around somewhere before talking to the Wizard, this happens.


Thanks for the reports, Yoshi! I was able to fix all of them except one for Build 60, let me know if you still see them. The switch texture issue is a stumper.

Hello friend, i do not know if this should be posted here, but i have a few problems. The pages in level one didn't appear to spawn at all, meaning i couldn't finish the quest, and in level 2, i do not know how to lead the NPC to the location which he wants to visit. 

ok, yeah this is not a bug. the pages do indeed spawn. you just need to use the friendly-vision (bound to weapon 4) to see them. and you don't need to lead the NPC to the location he wants to visit. you just need to go there, stand in the right spot facing the right direction so it takes the picture and then tell him about it. once you tell him, the quest is over.

Slightly disappointed theres no gags if you try to run it alongside Brutal Doom, like HDoom has

Less goof: any plans for Heretic/Chex Quest/etc compatibility down the line? Obviously it would be a later development, but could be fun.


I have a trello card for Heretic/Hexen/Chex Quest support, it'd just be a matter of doing all the writing: Not sure when I'll get around to it though.

(1 edit)

So.. I tend to get this crash-to-console error when scrolling through weapons. Usually happens when you finish a level, enter the next one and scroll through your weapons

I'm currently running GZDoom 3.3.2, should I use a devbuild?


Good catch, should be fixed in the build that just went up.

HELP! it says 

Script error, "friendly.pk3:friendly_zscript/ui.txt" line 1763:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 36:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 36:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 132:
Invalid statement when i run it in qzdoom or gzdoom


This seems to have started appearing with the most recent GZDoom, currently investigating.


This ended up being due to a bug in GZDoom itself, which has now been fixed. The next official release of GZDoom, whether it's 3.7.3 or 3.8, should contain this fix. If you don't want to wait until then you could try downgrading to an earlier version of GZDoom like 3.6.*


GZDoom 4.0 was just released, and fixes this:

So, enemies descriptions don't appear, and I don't know how to fix that :/


When you press spacebar, does a dialog box come up? NPCs don't have descriptions the way objects do, but you can interact with them to talk.

This happens when I start the game


Are you loading any other mods? Which IWAD are you using, Doom 2?

Oh, its because of something in my autoload, probably the voxels. Never mind

Just to mention i made some tries with heretic for fun and it works pretty great with it too. Only difference is that objects needs name and descriptions. Also the "computer map" equivalent can't be even taken, probably because it's not yet coded to be usable or something. but except for these two details, it works perfectly. ^^


Yeah, in the last build I made a while back I "stubbed in" Heretic support but didn't do any of the actual writing. The automap powerup is a good catch, that will require a tiny trivial code change. I'll make sure I do that before claiming any "official" Heretic support.

Ok nevermind. I could get the map and it worked like the automap should. The problem was me not using the right tool. That made me spot another problem tho, that also happens with usual doom iwads.

When you end a level with the glowing-eyes power, you start the next level with this power as the active "weapon", but the power as inactive. (no journal pages appearing, no golden view effect) And since it looks similar to the picking up things 'weapon" but can't actually grab things in that state, the confusion happened to me. :p

Maybe a good fix would be to make the player start the level with the picking up things "weapon" set on by default. ^^

Sometimes, I am unable to close the Quest screen which blocks/breaks the game. It appears to happen when I have Quest screen open and then open the Automap.


Hmm,  I can't seem to reproduce this (by opening the quest screen, then opening the automap). Are there any other steps you know of that can cause this to happen reliably?

(1 edit)

I was just able to reproduce this bug. It was to get stuck on the Inventory screen this time. Here are the exact steps I used. It happened at least twice in this exact way.

gzdoom -iwad DOOM2.WAD -file friendly.pk3 -warp 02

Completed camera quest, entered the secret area, collected both keys, completed the fishing quest, opened Inventory, opened Automap, closed Automap, unable to leave Inventory screen.

I hope this helps to reproduce the bug so it can be squished.

EDIT: additional conditions that may or may not have been present at the time; the level's alternate music CD was playing; the teleporter in the level was used at least once; neither of the level's switches had been activated; the problem ocurred while physically inside the exit room with the quest giver.


Thanks for this info, very helpful. I'm not able to reproduce the bug yet, but there's enough info that I can try a few things.
Two more questions, which exact version of GZDoom are you running, and on which OS?

GZDoom g4.3.3, according to terminal output

Ubuntu 18.04.2

Developer (1 edit)

Okay, I've got 4.3.3 compiled on my laptop which runs a distro based on 18.04 (though it seems unlikely OS has anything to do with this). I am still unable to reproduce this. The steps I followed were:

  1. Run with "gzdoom -config fresh.cfg -iwad doom2.wad -file friendly.pk3 -warp 2"
  2. Grab the CD straight ahead from the level start.
  3. Without bothering with the switch, slip through the gap into the hallway and go to the "house" area where the camera quest giver is.
  4. Talk to the camera quest giver, do the quest, turn it in.
  5. Fly in through the opening into the level's only secret room.
  6. Fly out and grab the red key.
  7. Fly back into the secret room and take the teleporter back to the level start.
  8. Slip through the other gap into the other hallway, and head to the sunken area with the barrels.
  9. Grab the blue key. Head through the two blue key doors into the exit room.
  10. Talk to the fishing quest giver in the exit room.
  11. Go right outside into the hallway and fish in the water there. Catch the fish.
  12. Turn in the fishing quest with the guy in the exit room.
  13. Press E to bring up the Inventory screen.
  14. Press Tab to bring up the automap.
  15. Press Tab to dismiss the automap.
  16. Press E to dismiss the Inventory screen. (Alternately tried clicking the checkmark button to close the Inventory screen, same result.)

Do these steps reproduce the issue for you?

If you're comfortable capturing some video of a session, that might be useful.

Thanks for the info, sorry this is a weird one.

(1 edit)

I've been unable to reproduce this behavior on this level a third time.

This is indeed a weird one. I thought for sure if I managed to get it happen twice that it would happen reliably under the same circumstances.

It just so happens I'm set up to record play sessions, and I enjoy lounging around in Mr. Friendly on my time off. The bug happened on a completely different level just yesterday (at the time, I thought I had reproduced it already so I've forgotten where exactly it happened) It seems to be quite rare, but I'll try to track it down and hopefully provide reproducible circumstances and video evidence to go over.

Thank you for working with me on this.