Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Mr. Friendly

Randomly Generated Acts Of Kindness · By JP LeBreton

Known issues with current build Sticky

A topic by JP LeBreton created Mar 27, 2018 Views: 1,942 Replies: 46
Viewing posts 21 to 23 of 23 · Previous page · First page

This happens when I start the game

Developer

Are you loading any other mods? Which IWAD are you using, Doom 2?

Oh, its because of something in my autoload, probably the voxels. Never mind

Just to mention i made some tries with heretic for fun and it works pretty great with it too. Only difference is that objects needs name and descriptions. Also the "computer map" equivalent can't be even taken, probably because it's not yet coded to be usable or something. but except for these two details, it works perfectly. ^^

Developer

Yeah, in the last build I made a while back I "stubbed in" Heretic support but didn't do any of the actual writing. The automap powerup is a good catch, that will require a tiny trivial code change. I'll make sure I do that before claiming any "official" Heretic support.

Ok nevermind. I could get the map and it worked like the automap should. The problem was me not using the right tool. That made me spot another problem tho, that also happens with usual doom iwads.

When you end a level with the glowing-eyes power, you start the next level with this power as the active "weapon", but the power as inactive. (no journal pages appearing, no golden view effect) And since it looks similar to the picking up things 'weapon" but can't actually grab things in that state, the confusion happened to me. :p

Maybe a good fix would be to make the player start the level with the picking up things "weapon" set on by default. ^^

Sometimes, I am unable to close the Quest screen which blocks/breaks the game. It appears to happen when I have Quest screen open and then open the Automap.

Developer

Hmm,  I can't seem to reproduce this (by opening the quest screen, then opening the automap). Are there any other steps you know of that can cause this to happen reliably?

(1 edit)

I was just able to reproduce this bug. It was to get stuck on the Inventory screen this time. Here are the exact steps I used. It happened at least twice in this exact way.

gzdoom -iwad DOOM2.WAD -file friendly.pk3 -warp 02

Completed camera quest, entered the secret area, collected both keys, completed the fishing quest, opened Inventory, opened Automap, closed Automap, unable to leave Inventory screen.

I hope this helps to reproduce the bug so it can be squished.

EDIT: additional conditions that may or may not have been present at the time; the level's alternate music CD was playing; the teleporter in the level was used at least once; neither of the level's switches had been activated; the problem ocurred while physically inside the exit room with the quest giver.

Developer

Thanks for this info, very helpful. I'm not able to reproduce the bug yet, but there's enough info that I can try a few things.
Two more questions, which exact version of GZDoom are you running, and on which OS?

GZDoom g4.3.3, according to terminal output

Ubuntu 18.04.2

Developer (1 edit)

Okay, I've got 4.3.3 compiled on my laptop which runs a distro based on 18.04 (though it seems unlikely OS has anything to do with this). I am still unable to reproduce this. The steps I followed were:

  1. Run with "gzdoom -config fresh.cfg -iwad doom2.wad -file friendly.pk3 -warp 2"
  2. Grab the CD straight ahead from the level start.
  3. Without bothering with the switch, slip through the gap into the hallway and go to the "house" area where the camera quest giver is.
  4. Talk to the camera quest giver, do the quest, turn it in.
  5. Fly in through the opening into the level's only secret room.
  6. Fly out and grab the red key.
  7. Fly back into the secret room and take the teleporter back to the level start.
  8. Slip through the other gap into the other hallway, and head to the sunken area with the barrels.
  9. Grab the blue key. Head through the two blue key doors into the exit room.
  10. Talk to the fishing quest giver in the exit room.
  11. Go right outside into the hallway and fish in the water there. Catch the fish.
  12. Turn in the fishing quest with the guy in the exit room.
  13. Press E to bring up the Inventory screen.
  14. Press Tab to bring up the automap.
  15. Press Tab to dismiss the automap.
  16. Press E to dismiss the Inventory screen. (Alternately tried clicking the checkmark button to close the Inventory screen, same result.)

Do these steps reproduce the issue for you?

If you're comfortable capturing some video of a session, that might be useful.

Thanks for the info, sorry this is a weird one.

(1 edit)

I've been unable to reproduce this behavior on this level a third time.

This is indeed a weird one. I thought for sure if I managed to get it happen twice that it would happen reliably under the same circumstances.

It just so happens I'm set up to record play sessions, and I enjoy lounging around in Mr. Friendly on my time off. The bug happened on a completely different level just yesterday (at the time, I thought I had reproduced it already so I've forgotten where exactly it happened) It seems to be quite rare, but I'll try to track it down and hopefully provide reproducible circumstances and video evidence to go over.

Thank you for working with me on this.

Viewing posts 21 to 23 of 23 · Previous page · First page