Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Asset Forge

Create your own 3D models and 2D sprites! · By Kenney

[Linux] CPU usage constantly at 100%.

A topic by Splizard created Feb 03, 2018 Views: 133 Replies: 4
Viewing posts 1 to 5

I am using the software on my laptop and it uses 100% of a single cpu when idle. Even with zero blocks added to the scene, the laptop will heat up and turn it's fan into overdrive.

As a comparison:
Blender uses 3-15% of a single CPU while idle.
The Godot engine uses 15% idle CPU and 85% cpu when moving the camera.

Why would Assetforge need to use this much CPU? Can you disable redrawing of the screen when there is no user input?

Hey Splizard, thanks for the bug report! Could you let us know which version of Asset Forge you're using? It'll help us solve the issue.

Sure, it's the 1.3 Beta version. I had some success limiting the CPU that Assetforge can use to 85% but this affects the performance of camera movement.

(+1)

Hm, that sounds like a problem indeed. We're currently working on a complete remake of the application which will be released as a free update, hopefully that'll solve a lot of performance issues. Some of the techniques we used back when we first wrote the software are quite bad, and might explain the high CPU load.

Although you probably don't care at this point, given the rewrite, it only seems to spike my CPU when the window loses focus.  When I'm actually in the window, it drops down to minimal usage.  I'm also using 1.3 Beta.