🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bug Reports Sticky

A topic by Cynapse created 1 year ago Views: 1,022 Replies: 29
Viewing posts 1 to 22
Developer (Edited 2 times)

Here's the place to put all bugs/issues with the game. Make sure to let me know what OS you're running on, and explain the steps you took to get the bug. More information is better!

I'll periodically clear fixed reports to keep this thread clearer for myself.

Was goofing around with console stuff till next release. Found things that could affect a real game.

If you get tendril mutation then extra limbs, they replace the tendril in your primary hand location so you can wield a weapon again. The tendril in your offhand remains. On the other hand, I'm not sure it does anything, it is listed as a polearm, but when you fight you don't get improvements in polearm, offhand, or unarmed. Not sure if the primary weapon tendril increases skills.

If you have wings (and I suppose dorsal fin) you can't use the bio-battery (whatever it is called), as it is a back location, and that means you can't use anything powered by it. Maybe give it, it's own location. Or just have wings not cover the back location.

This reminds me of an idea I'd had before. since you can amputate and attach additional limbs, why not allow it as an alternative to mutate. Find an interesting leg, just add it as a third leg, cut off some wings, and attach them. That might make it too easy to get extra arms or wings or such, but since the bonuses for most of them are lower it might not be a huge issue.

Developer

Good catches. Creeping Tendrils as a weapon should be considered unarmed, not polearm. I'll fix that after work today, same with the extra limbs clearing mutation-specific weapons.

Bio Cores do need to be changed, as you can't use high-level armour or weapons without one, and wings or a fin do make that impossible. I have a few ideas on how to make this better, though I'd prefer not to add a whole new slot just for Cores.

  • Make more bio core items that attach to other slots.
  • Bio Cores are automatically used when in your inventory. You just give up one space in there instead.
  • Bio Cores "clip-on" to weapons/armour.
  • Powered equipment uses charges upon use. Bio Cores are consumables and act like Fusion Cores for rechargeable items. (Not keen on this idea)
  • Bio Cores can be equipped in any slot, but take up the whole body part.
Attaching limbs to an area that wouldn't support another limb isn't something I have planned. It's a cool idea, but ultimately will lead to massive lists of parts over time. Maybe I'll find a way to balance it in the future, but for now the idea isn't too tempting. I like the "dice roll" that is the mutation system.
That being said, I do have a really cool idea for how parts can be of use to you beyond waiting for a limb to be chopped off. Familiars will be built using various parts in a Frankenstein-like fashion upon finding the correct NPC, and giving them the best parts you can find. The character's stats and body structure would be completely up to you, and perhaps multiple creatures can be created, giving you an army of eight-headed, four-armed, no-legged monstrosities. Or whatever you'd choose to make. This idea isn't too far in the future either!
0.4.5 will be released tonight (tomorrow morning for most, since I'm on the west coast of Canada) after I get those mentioned bugs ironed out.

A quick thing. Some quirkiness in quests. I took the initial quest, then selected the Spelunking element (first component) in journal and going into the dungeon it didn't register. Restarted game, took quest but didn't select using the journal, and it registered fine.

Developer

Huh. That's strange. The only thing selecting the quest does in the journal is sets it to your tracked quest. Must be something else going on here. I'm assuming it's saving and loading fine for you now

Yes. Tested that and it is fine. I haven't had time to test the current version thoroughly, just tested saving/loading, and saving your preset options. Those all work now.

Had a Quest to kill 5 bats, when I was returning to the village with the exclamation point in the world map, they were being attacked by bandits, the quest giver died and the quest was failed but the exclamation point in the world map didn't went away.

I'm playing with mouse on Windows, and every time I trade with someone my inventory displays only the first 4 items and at the end a "Dagger" with no value. But when I select the Dagger, the info window shows the next item in my inventory, it's really wierd, it's always the same result every new game.

Developer

Thankfully, the second one has been fixed for the next release. There were a bunch of things wrong with the shop panel.

I'll get rid of the world map quest marker upon failing the quest.

Thanks for posting :)

My saves seem to be broken, everytime i relaunch the game i am missing most of the UI and my character only moves one square before they are stuck. Where are the save files i can give you a copy.

Developer

No need, that issue has been fixed for the next release :) It has to do with status effects, and the dictionary not being initialized at run time.

(Edited 1 time)

Weird stuff happening here with the new 0.4.6 build.

Seems the game is permanently stuck on the main menu screen with the "loading..." message permanentely on. Funny enough, some menu buttons like map editor, options gear do respond. But when I click on "new game", it pushes me back to main menu a sec after.

Tried both 32 and 64 Win versions. Win 10 here.

Developer

Do you have any previous save data from older versions of Axu?

The path would be Users/Your name/AppData/LocalLow/Ravensong Games. If you have save data, try deleting it. I'll check this out after work. I attempted to erase version specific bugs, but it may have backfired.

Hey, it worked! Thanx so much! =)

(Edited 1 time)

The new build runs wonders so far! Quite enjoying it.

Some glitches nevertheless:

1. The mobs are dead. But their sprites with healthbars still stay onscreen. Btw, when mobs dropped items, item sprites appered below mob sprites, when picked up item icons cleared as they should be. The I moved to other screen, mob icons are still haunting my char... O.O Restarting the game helps but only till next combat then it glitches again with next mobs.

https://i.imgur.com/CRA3i8x.png (initial screen)

https://i.imgur.com/Z9D98zW.png (the other screen)

upd. even restarting PC didn't help. But the glitch cured by itself after a while..

Developer

I see you've stumbled upon the "remorse" feature of Axu. Your character feels guilty about the creatures and people they've murdered, so ghosts from the past haunt you.

Kidding, that's definitely a bug. Must be some kind of exception occurring before death, causing the object not be be destroyed.

Glad to hear it's running well other than this issue though :)

(Edited 1 time)

*Sigh*

Well, played for a couple of hours until *suddenly* the game began to freeze every now and then. Reloaded, and it began to load savegame...for eternity. I guess save became corrupt or smth. Maybe it was cause I stashed like 50+ items on the ground in one town sector? Dunno.

Will try again tomorrow and see if those pesky bugs return! :)

Btw, at times it made my i5 2.5GHz with 4GB Geforce & 8GB Memory laptop...well, not actually burn, but close to that point. :)

Maybe should switch to 32-bit version, huh?..

upd. it seems that changing Geforce drivers from OEM to native resolved the temperature issue.

2. The haunting continues! :) Entered new sector, killed a mob and the lights went off! Light, line of sight not displaying anymore. Entered another sector to test, total blackout :)



Reloaded game, found my char in the middle of nowhere:

https://i.imgur.com/DPucOyD.png

(Edited 1 time)

Aha! I think things are getting somewhere (hope at least). Restarted Axu several times, both 64 and 32 bit versions. At some point there were same freezes, saving and loading took more time and in the end save won't load. But at least it gave back error logs! :)

Uploaded them to GDisk and shared access. Hope that helps! :)

Developer

Wow, you've covered so much ground, and seen so many NPCs that you're out of memory when accessing the file! :P

.I'll slim down save files, and start doing some culling of old areas to remedy this. I started a save and had it roam the world for 20,000 turns, saw the same results as you while attempting to start the game. Saving and Loading, as of a change 15 minutes ago (available in the next release, hopefully soon) screens are loaded at the moment you enter them rather than all at once.

Thanks again for the reports :D

(Edited 3 times)

Loading saves messes up skills and stats. Had helmet that increases accuracy to 3 from 1, reloaded save I then had 1 accuracy with the helmet on, taking it off lowers my accuracy to -1.

Loading my game changes my polearms skill to axes for some reason.

Upon loading my character may drop his entire inventory. Thinking this may have to do with items that increase inventory space.

Traits on the character screen run off the page

Bosses don't generate at the bottom of dungeons anymore. Not sure if this is intentional.

Running windows 10 with the 64 bit version

Developer

Thanks for the bug reports! A couple of these have already been fixed for the next update, but I'll double check to make sure it's working properly. :)

(Edited 1 time)

Bug report:

Thrown items go into walls and can not be picked back up (intentional?)

Doctor did not take money when replacing leg with peg leg

Walls look black in ruins (intentional?)

After stunning an enemy they will sometimes follow you while still stunned or while their graphic still shows as them laying down

Upon arrival when escorting an NPC to the Cathedral the quest ends but the quest icon above their 

head remains and you need to speak to them again to complete the quest

When fighting against 2 test subjects in the ARENA I killed 1 and the other was teleported out of the arena (instead of me?) and I was unable to escape

Correction: I was able to leave the Arena by using the Map function (probably not intentional)

I have completed the power plant terminal turning on mission multiple times but 1 time I was unable to find the final terminal, each floor had 2 terminals except for 1 floor - I searched for a very long time and believe it somehow did not spawn/place correctly?

Certain walls (in the prison and elsewhere) did not vanish after being pickaxed though LOS and enemy AI still worked and allowed both NPCs and I to travel through the unseen opening

I have removed the prison anklet by having a doctor swap it and had the gentleman in the basement remove it but I do not believe my stats actually changed? (perhaps I am mistaken)

When fighting the Specter I saw a message with html(?) code visable. Something like:<size=10></size>Stamina leeched by Specter</color>

These are what I found so far - going to explore some more tomorrow.

I was playing a Murderer and am using Windows 8.1.

Let me know if you need additional information - more than happy to help!

Developer

Good catches :)

I've gone ahead and fixed a few of these issues. The Areana teleportation was an oversight by me. The Test Subjects have the ability to teleport, so I've swapped them out with another enemy type.  I'm still working on items and other features being placed into walls, as it shouldn't be possible. Obviously I've missed something!


Thank you so much for the report!

Teleport ability RNG is seriously messed up. I got teleported into a wall and then proceeded to try to teleport out of it for like 30 times, just to be moved betweet 3 or 4 same spots at the top of the screen...

Developer

The Y coordinate is messed up, yeah. It's fixed in the next version, which is out soon :)

(Edited 2 times)

Cool, thanks.


It also placed the up stair at my position (inside the wall) after save/load. So i could get up a floor. Going down a floor placed me where the original up stair was, but the other one was still embedded in the wall. I had to use a gem to bail out  to the surface.

When using thrown weapons when below ground then the thrown items land above ground. (I guess the height parameter do not get set.)
---
Having a doctor replacing limbs: Keyboard commands do it, but it do not work with the mouse-device. (I use Win 7 - 64 bit.)
It is needed to have $550 for doing so, but nothing is paid for the operation?!
---
When having more than two arms it is possible to use a two hand weapon while using an off-hand item, but it is needed to equip the off-hand item before wielding the two hand weapon. (Annoying when replacing the off-hand item.)
---
The Experiment: Is stated to start with 5 in all four stats, however if starting with no leg, and thus no prison inhibitor, all four are 4 instead.
---
When having played for several hours, it suddenly become impossible to move. (Reloading the game fixes it.)
---
When returning to the ship builder with the 7 mysterious ore, I got a message about I had to do something for someone before the ship was ready, but I got no mission for that. ("Show stopper bug" in that I thus got stuck in the story.)

*** Some not exactly "bugs", but "weird behaviours" none the less:
Random map generation: The Ensis Stronghold can be entirely surrounded by mountains. I have seen that twice, where I restarted.
I did a lot experiments with wings and some hover boots, but none of them allowed me to climb mountains.

Later I figured out it is possible to dig through mountains. (Though I can still not walk through my tunnels at the main map)
There are some hints about treasures in mountains, and when I figured to dig my way, I managed to find some abandonned buildings inside the mountains.

But still I think things can be made a bit more logical here.
---
For the power plant I had an example of only one terminal at the bottom floor.
I guess it could have been inside the walls, I did not think of trying to dig for it by then.
I solved it by turning on a terminal somewhere far away from the power plant!?
There are a quest to find an artifact at the bottom of the Volcano, I once had to dig into the walls to find and slay the dude having it. (At least the quest giver supplied a pick-axe.)
---
The Volcano: Swimming around in the red liquid in the center (Lava?) is a surprisingly effective way of improve the armor skills.
---
Spoilable items do only detoriate while carried.
---
I had a game where I was running around for hours searching for "Mysterious liquid" for the quest, (Yeah, I got one before the quest, but I had drunk that one when I got the quest.) eventually giving up and restarted.
---
When replacing an arm, the text changes from "Right arm" to "Ensistic arm", but when doing it with a leg, it still say "Right leg".
Amputating an "Ensistic arm", picking it up and reataching it it become: "CharName's Arm" with stats: Hunger (400) Strength (1).
---
Some of the extra limbs do not get their stats displayed.
---
There are quite some situations with items having colored prefixes not getting those displayed when equipped.
---
Some quest where more than 1 have to be collected, the quest giver only take 1 on completion.

*** Nice to have:
Character: Stats displayed with three numbers each (columns): Base, sum of modifiers and  total.
Thus strength of 5 with prison inhibitor would be shown as:
STR: 5  -1  4
---
Stats it would be nice to be able to see:
DEF:
Vision + light level:
---
More scroll bars! Many lists can have more items than can fit in their frames. (Abilites, Items and traits being some often having more than can be displayed.)
---
Auto pick up of thrown items. (Could be nice to just have to walk over stack-able items for to collect them.)

Developer

Thank you for all this! I'll have to go in depth later on.  A bit pressed for time at the moment.
In regards to no quest being given to you after the Ore pieces, that's the last quest in the line at the moment. The story is still in the works!

Defense is limb based, and items equipped only protect the limb they are on, so a defense stat does make sense, but on the limb screen (I could have sworn I put that in there...)

I'll do another reply once I have some spare time. Thank you again! :D

The bug with player's character getting stuck seems to be caused by ripostes – at least on linux 0.4.6 build every time it happened to me it was after a riposte. Would also explain why it happens only after several hours of gameplay.
BTW the linux download shows it got updated on June the 22nd but it is still 0.4.6,  just signalling in case it is accidental.

Developer

Definitely accidental, as I uploaded the wrong folder. I updated it to 0.5! Let me know if you are still having the same issues with the real new version.

Ok, so I have completed the game as it is so far.

Limb based, Ok, that would explain why I still take damage from fire based actions when having 100 % total in fire resistance. But why then sum together fire and cold resistance?

I can add a few more bugs: In the Power Plant I once had a seed spitter standing at a wall tile, thus could see it but not attack it, and the game became laggy while it was in sight.

I once had two similar missions at the same time: Escort a person to the cathedral, but when I arrived I only got one mission completed message but both did disappear from the journal, and one of the two persons did continue to follow me around.

I once bought all the goods a merchant had. It became impossible to trade with that merchant again.

when doing an arena battle enimies that can teleport leave the arena and i become stuck there.

Developer

Are you sure you're running 0.5? I removed those enemies from the arena battles last update. 

Hi, version 0.50 on Windows 10: sometimes, while RESTing with E I found out I stopped recovering health/stamina like REST got stuck.

Move one tile and "E" and it works again.

Cheers,

p.

When playing Heretic and cast a, "Lightning Bolt," if I mis-click and press num5, my game crashes.