Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Bitsy Game Maker

Make little games, worlds, and stories! (No coding required.) · By Adam Le Doux

Bitsy v4.0 bugs!

A topic by Adam Le Doux created Nov 04, 2017 Views: 818 Replies: 30
Viewing posts 1 to 12

Bitsy 4.0 is released! It has some exciting new features but there are probably some new bugs as well. ;) I'm putting this thread up as a place to report any bugs you notice that you think may be new in 4.0. 

This would be an especially good place to post if you find any bugs related to items or dialog. Thanks for your help!

(+1)

Hey, Adam! Just tried it and it's awesome!

Idk if others also experienced it but:
> When I start a new game (to refresh things), the dialogs from the previous one tend to stick around, confusing the new ones.
> A default dialog and a conditional one are mushed together after the item is found. So now whenever I clicked the cat, it says two sentences at the same time ;A; This is resolved when I put the default dialog within the conditional section, so I'm still a little confused on how to use the normal 'dialog' section properly. Is this a bug or this something I misunderstood?
> So I made two items for the sprite to compare: let's say apple, and actual apple. At first, when I only introduced apple, the sprite says the intended dialog, "Not my apple". But after I added the second item: actual apple, with added condition and everything, the sprite kept saying "Not my apple" when in reality I've added a new dialog for it to say "YES that's my apple!".  | So I deleted the first item, the apple, and deleted the reaction dialog as well, the sprite magically kept saying the deleted dialog: "Not my apple". 
I'll let you know if I can find more in the future, but for now the interconnecting reaction between several conditions seem to be the main problem. Otherwise, it's a super exciting feature, can't wait for it to develop!

hi - thanks for the bug report & feedback! :)

> I'm having trouble making the dialogs stick around when I start a new game. Can you tell me more about how you made that happen?

> I'm not sure, but I think what you're describing with the default dialog and the conditional one is the intended behavior. You're supposed to be able to string them together so you can have a sprite say: dialog -> list dialog -> conditional dialog -> dialog. It just plays them top to bottom. If you only want it to say one thing or the other, then you need to only have the conditional dialog, like you describe. I should think if I can make it more clear in the UI.

> For the item issue - I just updated bitsy with some dialog bug fixes. Can you try again and see if it works for you now? If not let me know :)

Oh I simply started a new game! I made something with the new dialog features, but I wanted to try something else, so I made a new game. It appeared as if everyhing was reset, but when I pressed play after i edited/the other way around, the old dialogs are still in the item/sprite, and they're mushed together with the new ones.

hey! So due to this new update all the old room names disappeared and although you can write a name into the room boxes. They're not saved in any way. Because of this I can no longer place any new exits and none of the rooms have any names at all anymore. 

Thanks!

(1 edit)

Similar issue here, though not as bad. I save and load by copy-pasting to and from the game data window, because reasons. The name of the very first room is never saved OR restored -- I checked by modifying the game data manually. All rooms added later have their names preserved. Project is newly started in version 4. Hope this helps.

Edit: correction, the name of room 0 is saved and restored with the game data, just not shown in the room tools tab.

P.S. I dunno if it makes a difference, but I started by modifying the default room instead of making another and deleting the default one.

@lzln: can you post a screenshot of the issue you're seeing? I'm having trouble reproducing it on my end. are you saying there is nothing in the dropdown to select the room an exit goes to?

@No Time To Play: Does the room 0 name appear if you click "next room" then "previous room"?

(+1)

It does now.

When I opened the inventory panel on Firefox 54, there is a single item "tea" and a variable "a".  There doesn't appear to be a way to add new items, though there is a new variable button.

On Chromium, there is no way to add new things, and no default things at all

Perhaps you need to create an item in the paint dialog before you can add it to the default inventory.

Just verified that there is, in fact, a tea item in the paint dialog, and yet nothing in the inventory dialog.

(2 edits)

You're right, nothing shows in the inventory window until you've played the game once, or at least tested a dialog. That's a bug in itself. But after that, any item you create will be listed in the inventory, and you can set how many you have initially.

is the inventory window just empty? and this is with a new game?

Yes, the inventory window is simply empty in both tabs. This happens with a brand-new game before pressing Play even once. It doesn't happen (anymore?) with an existing game that was just loaded back into a fresh session.

(+1)

thanks for your help! I think I've figured out the issue here -- I'll have a fix out soon :)

hi! to add items, you need to do that in the paint window - maybe I should add a button to do that in the inventory window also.

for the chrome bug, are you on windows? I don't see the issue on mac

Not sure if this is new to 4.0, but when I duplicate a sprite the sprite appears as a null in the game data. I can place these duplicates in a room but they are not actually interactable, though they will show up when I run the game.

Update: also facing this issue sometimes when just making a new sprite

that's not good! does this happen every time you duplicate a sprite or just some of the time? do you remember what else you did before you duplicated it? and what OS and browser are you using?

     It was just happening sometimes. Nothing is standing out to me as something specific I was doing before this happened. It felt like it had something to do with the Find Drawing window being open but I have no way to corroborate this. I'll try to keep track of what I'm doing in case the null sprite thing happens again.
OS: Windows 10
Browser: Chrome

     While trying to recreate this I did notice a couple things; deleting a sprite with dialogue doesn't remove the dialogue from the game data. Similarly if you delete a sprite the sprite still exists in the Find Drawing window. Then, if you click on a deleted sprite in the Find Drawing window and then click the duplicate button, the deleted sprite is 'duplicated' instead of the sprite that is actually open in the Sprite window.

thanks for the extra details! those other bugs are good ones too - I'm working on fixing them

Not sure what causes it but sometimes when writing dialogue that uses the new text effects I'll go to play the scene and it won't fire the dialogue attached to the sprite when interacted with. Deleting the {rbw} tags then Play again the text fires fine, then repopping in the tags makes it work fine after that.

hmm, if this happens again can you send me the game data? I haven't been able to make it happen for me yet

I will do!

(+1)

hey folks! thanks for the bug reports. I'm investigating these now and I'll let you know what I find. I may reply to your individual posts with some questions if I'm having trouble reproducing your bug or something :)

Another minor thing:

  • open new Bitsy session;
  • paste existing source code into the "game data" window;
  • open the "find drawing" window;
  • the avatar displayed in "find drawing" is the default one, not what is defined in the game;
  • if you change the tab and come back, the right avatar appears.

This can't break anything, of course, but it might confuse some people.

(+1)

thanks! good catch!

(1 edit)

it seems impossible to drag a window right of the rightmost window (and if the dragged window is the rightmost, impossible to drop it back in its place if it's already been dragged over to another but not dropped yet)

workaround: drag the rightmost window left instead

edit: in case it matters i'm using the "desktop" version on linux (apparently the itch-supplied self-contained browser)

dragging on the sprite editor causes page elements to be selected

after dragging from the sprite editor to outside it, then back inside, no more pixels will be placed

(1 edit) (+1)

not sure if this is new to 4.0, but sometimes when pushing an arrow key just once, the avatar will keep moving in the direction until it runs into a wall/sprite. once this happens, all consecutive arrow key input will have the same result. usually refreshing the window will fix this.

edit: also, when trying to play on mobile, i can't get the screen to show the full game. this may be an issue with my itch viewport settings, but i'm not sure. 

I couldn't download my game at all, is there a fix?